rpcsvc-proto: set as buildonly
authorAndy Walsh <andy.walsh44+github@gmail.com>
Fri, 3 Jan 2020 19:03:33 +0000 (20:03 +0100)
committerAndy Walsh <andy.walsh44+github@gmail.com>
Fri, 3 Jan 2020 19:03:33 +0000 (20:03 +0100)
* set package buildonly

Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
libs/rpcsvc-proto/Makefile

index 5a6e954e55a2a028ac8f6b9eb5eb1b6fd34f10ab..0726ed663c034ae242e9eab75f17ae16a54e9977 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcsvc-proto
 PKG_VERSION:=1.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=https://github.com/thkukuk/rpcsvc-proto/releases/download/v$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -28,6 +28,7 @@ define Package/rpcsvc-proto
   TITLE:=rpcgen and rpcsvc proto.x files from glibc
   URL:=https://github.com/thkukuk/rpcsvc-proto
   DEPENDS:=$(INTL_DEPENDS)
+  BUILDONLY:=1
 endef
 
 define Package/rpcsvc-proto/description
@@ -44,14 +45,6 @@ endef
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/rpcsvc $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rpcgen $(1)/usr/bin/
-endef
-
-# do we need rpcgen on target?
-define Package/rpcsvc-proto/install
-       # $(INSTALL_DIR) $(1)/usr/bin
-       # $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rpcgen $(1)/usr/bin/
 endef
 
 $(eval $(call HostBuild))