klish: fix compilation with GCC14
authorRosen Penev <rosenp@gmail.com>
Sun, 19 May 2024 02:22:19 +0000 (19:22 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 26 May 2024 08:32:57 +0000 (01:32 -0700)
Proper types are now needed.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/klish/Makefile
utils/klish/patches/010-shell_execute_fix.patch

index 018af96bb6abbcb0e6d3f904a19a97f9f87131f1..a14a4025d9310284036a0e628a98c96a0c463d2e 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=klish
 PKG_VERSION:=2.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://libcode.org/attachments/download/82
index 822736259d58fb11f1bda00856a9c6942e44c41a..e62cb2252653ae450fb88ea937f4984fb4d46a6a 100644 (file)
@@ -1,17 +1,20 @@
 --- a/clish/shell/shell_execute.c
 +++ b/clish/shell/shell_execute.c
-@@ -19,12 +19,14 @@
- #include <signal.h>
+@@ -20,7 +20,7 @@
  #include <fcntl.h>
  
-+#if 0
  /* Empty signal handler to ignore signal but don't use SIG_IGN. */
- static void sigignore(int signo)
+-static void sigignore(int signo)
++static void sigignore2(int signo)
  {
        signo = signo; /* Happy compiler */
        return;
- }
-+#endif
- /*-------------------------------------------------------- */
- static int clish_shell_lock(const char *lock_path)
+@@ -361,7 +361,7 @@ int clish_shell_exec_action(clish_contex
+        */
+       sa.sa_flags = 0;
+       sigemptyset(&sa.sa_mask);
+-      sa.sa_handler = sigignore; /* Empty signal handler */
++      sa.sa_handler = sigignore2; /* Empty signal handler */
+       sigaction(SIGINT, &sa, &old_sigint);
+       sigaction(SIGQUIT, &sa, &old_sigquit);
+       sigaction(SIGHUP, &sa, &old_sighup);