auc: link to libdl when needed
authorRosen Penev <rosenp@gmail.com>
Wed, 30 Dec 2020 23:17:49 +0000 (15:17 -0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 31 Dec 2020 00:36:52 +0000 (16:36 -0800)
Fixes compilation under glibc.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/auc/Makefile
utils/auc/src/CMakeLists.txt

index 0b44d0e5d72579010c1b077404d3221c30665a47..40cb6d1851dde4b604525e299a947499b912a011 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=auc
 PKG_VERSION:=0.1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-3.0
 
 include $(INCLUDE_DIR)/package.mk
index ce291a4e3483cd8275768fc126005092161a299f..de6cee83340605b5b33392212f7aa888e0f8aa82 100644 (file)
@@ -8,5 +8,5 @@ SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 find_library(json NAMES json-c json)
 
 ADD_EXECUTABLE(auc auc.c)
-TARGET_LINK_LIBRARIES(auc uci ubox ubus uclient blobmsg_json ${json})
+TARGET_LINK_LIBRARIES(auc uci ubox ubus uclient blobmsg_json ${json} ${CMAKE_DL_LIBS})
 INSTALL(TARGETS auc RUNTIME DESTINATION sbin)