mwan3: use common makefile install wrappers
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 4 Nov 2020 11:07:14 +0000 (12:07 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Fri, 6 Nov 2020 09:35:55 +0000 (10:35 +0100)
With this change you can see at a glance which files will be installed on
the system.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
net/mwan3/Makefile
net/mwan3/files/etc/init.d/mwan3 [changed mode: 0755->0644]
net/mwan3/files/usr/libexec/rpcd/mwan3 [changed mode: 0755->0644]
net/mwan3/files/usr/sbin/mwan3 [changed mode: 0755->0644]
net/mwan3/files/usr/sbin/mwan3rtmon [changed mode: 0755->0644]
net/mwan3/files/usr/sbin/mwan3track [changed mode: 0755->0644]

index 99990e4cca26af7223f465cfbebfc159b297a24b..c603397daeb14322f8d86a09a9553688888f2136 100644 (file)
@@ -67,8 +67,43 @@ define Build/Compile
 endef
 
 define Package/mwan3/install
-       $(CP) ./files/* $(1)
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/etc/config/mwan3 \
+               $(1)/etc/config/
+
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/etc/hotplug.d/iface/15-mwan3 \
+               $(1)/etc/hotplug.d/iface/
+       $(INSTALL_DATA) ./files/etc/hotplug.d/iface/16-mwan3-user \
+               $(1)/etc/hotplug.d/iface/
+
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/etc/init.d/mwan3 \
+               $(1)/etc/init.d/
+
+       $(INSTALL_DIR) $(1)/lib/mwan3
+       $(INSTALL_DATA) ./files/lib/mwan3/common.sh \
+               $(1)/lib/mwan3/
+       $(INSTALL_DATA) ./files/lib/mwan3/mwan3.sh \
+               $(1)/lib/mwan3/
+
+       $(INSTALL_DIR) $(1)/usr/libexec/rpcd
+       $(INSTALL_BIN) ./files/usr/libexec/rpcd/mwan3 \
+               $(1)/usr/libexec/rpcd/
+
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/usr/sbin/mwan3 \
+               $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/usr/sbin/mwan3rtmon \
+               $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/usr/sbin/mwan3track \
+               $(1)/usr/sbin/
+
        $(CP) $(PKG_BUILD_DIR)/libwrap_mwan3_sockopt.so.1.0 $(1)/lib/mwan3/
+
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DATA) ./files/etc/uci-defaults/mwan3-migrate-flush_conntrack \
+               $(1)/etc/uci-defaults/
 endef
 
 $(eval $(call BuildPackage,mwan3))
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)