coova-chili: fix compilation with glibc
authorRosen Penev <rosenp@gmail.com>
Wed, 30 Dec 2020 23:40:44 +0000 (15:40 -0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 31 Dec 2020 00:34:30 +0000 (16:34 -0800)
Disable Werror as it errors on pointless stuff.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/coova-chilli/Makefile

index 517a022150c6f65fa0b5b27bdbac1fd06bfab183..094815c253d7ee4efe0702e782802373220beb78 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coova-chilli
 PKG_VERSION:=1.5
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/coova/coova-chilli/tar.gz/$(PKG_VERSION)?
@@ -82,7 +82,7 @@ endef
 
 DISABLE_NLS=
 
-TARGET_CFLAGS += $(FPIC) -Wno-address-of-packed-member
+TARGET_CFLAGS += $(FPIC) -Wno-error
 
 CONFIGURE_VARS += \
        ARCH="$(LINUX_KARCH)" \