busybox: Fix hexdump applet
authorHannu Nyman <hannu.nyman@iki.fi>
Thu, 19 Dec 2024 18:45:40 +0000 (20:45 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 20 Dec 2024 18:53:41 +0000 (19:53 +0100)
Fix the hexdump applet's formatting with certain format types
by applying the upstream fix for 1.37.0.

Also refresh patches.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/17308
[Changed to 002- patch file name prefix]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/utils/busybox/Makefile
package/utils/busybox/patches/001-fix-non-x86-build.patch
package/utils/busybox/patches/002-upstream-fix-hexdump.patch [new file with mode: 0644]

index c2fc609610e80ab6ab9ea720ae0c3c419e406acf..cda3be9f2f505d34a9a4e4e165a8d5befc6547b9 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.37.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index b33ec98bf29968ccf95caadec2991cfd428552a8..7a47292474fac4c1e2c564b73546f5f79d9f5294 100644 (file)
@@ -1,7 +1,5 @@
-Index: busybox-1.37.0/libbb/hash_md5_sha.c
-===================================================================
---- busybox-1.37.0.orig/libbb/hash_md5_sha.c
-+++ busybox-1.37.0/libbb/hash_md5_sha.c
+--- a/libbb/hash_md5_sha.c
++++ b/libbb/hash_md5_sha.c
 @@ -1313,7 +1313,9 @@ unsigned FAST_FUNC sha1_end(sha1_ctx_t *
        hash_size = 8;
        if (ctx->process_block == sha1_process_block64
diff --git a/package/utils/busybox/patches/002-upstream-fix-hexdump.patch b/package/utils/busybox/patches/002-upstream-fix-hexdump.patch
new file mode 100644 (file)
index 0000000..a123fe3
--- /dev/null
@@ -0,0 +1,49 @@
+From 87e60dcf0f7ef917b73353d8605188a420bd91f9 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 28 Oct 2024 15:26:21 +0100
+Subject: hexdump: fix regression with -n4 -e '"%u"'
+
+Fix bug introduced in busybox 1.37.0 that broke kernel builds.
+
+Fixes commit e2287f99fe6f (od: for !DESKTOP, match output more closely
+to GNU coreutils 9.1, implement -s)
+
+function                                             old     new   delta
+rewrite                                              967     976      +9
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ libbb/dump.c            | 6 ++++--
+ testsuite/hexdump.tests | 6 ++++++
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+--- a/libbb/dump.c
++++ b/libbb/dump.c
+@@ -198,9 +198,11 @@ static NOINLINE void rewrite(priv_dumper
+                               if (!e)
+                                       goto DO_BAD_CONV_CHAR;
+                               pr->flags = F_INT;
+-                              if (e > int_convs + 1) /* not d or i? */
+-                                      pr->flags = F_UINT;
+                               byte_count_str = "\010\004\002\001";
++                              if (e > int_convs + 1) { /* not d or i? */
++                                      pr->flags = F_UINT;
++                                      byte_count_str++;
++                              }
+                               goto DO_BYTE_COUNT;
+                       } else
+                       if (strchr(int_convs, *p1)) { /* %d etc */
+--- a/testsuite/hexdump.tests
++++ b/testsuite/hexdump.tests
+@@ -82,4 +82,10 @@ testing "hexdump -e /2 %d" \
+ "\x80\x81\x82\x83\x84\x85\x86\x87\x88\x89\x8a\x8b\x8c\x8d\x8e\x8f"\
+ "\xf0\xf1\xf2\xf3\xf4\xf5\xf6\xf7\xf8\xf9\xfa\xfb\xfc\xfd\xfe\xff"\
++testing "hexdump -n4 -e '\"%u\"'" \
++      "hexdump -n4 -e '\"%u\"'" \
++      "12345678" \
++      "" \
++      "\x4e\x61\xbc\x00AAAA"
++
+ exit $FAILCOUNT