bind: support compile-time exclusion of DNS-over-HTTPS support
authorNoah Meyerhans <frodo@morgul.net>
Thu, 3 Feb 2022 20:01:54 +0000 (12:01 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 8 Feb 2022 05:31:54 +0000 (21:31 -0800)
DoH is enabled by default, but disabling it removes the need to link
against libnghttp2, which may be desirable more constrained
environments.

Signed-off-by: Noah Meyerhans <frodo@morgul.net>
net/bind/Config.in
net/bind/Makefile

index ab27b18e3cb48fe52b01a19afdedf5901f75ded8..07bcc1c6326d487d0338098c52d29bae6f519d87 100644 (file)
@@ -20,3 +20,17 @@ config BIND_LIBXML2
                format. Building with libjson support will require the
                libxml2 package to be installed as well.
 endif
+
+if PACKAGE_bind-libs
+
+config BIND_ENABLE_DOH
+       bool
+       default y
+       prompt "Include DNS-over-HTTPS support in bind"
+       help
+               BIND 9 supports DNS-over-HTTPS and enables it by
+               default.  This requires linking against libnghttp2.
+               You can disable DoHTTPS if you do not need it or need
+               to avoid the additional library dependency.
+
+endif
index 7a05d1c6f929677e5cb109b57d4622d8a0f2c35e..5203d65a0536e3a7331fc736dabdcbf1ee04d101 100644 (file)
@@ -31,11 +31,10 @@ PKG_INSTALL:=1
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
 
-PKG_BUILD_DEPENDS:=nghttp2
-
 PKG_CONFIG_DEPENDS := \
        CONFIG_BIND_LIBJSON \
-       CONFIG_BIND_LIBXML2
+       CONFIG_BIND_LIBXML2 \
+       CONFIG_BIND_ENABLE_DOH
 
 PKG_BUILD_DEPENDS += BIND_LIBXML2:libxml2 BIND_LIBJSON:libjson-c
 
@@ -59,7 +58,7 @@ define Package/bind-libs
        +libpthread \
        +libatomic \
        +libuv \
-       +libnghttp2 \
+       +BIND_ENABLE_DOH:libnghttp2 \
        +BIND_LIBXML2:libxml2 \
        +BIND_LIBJSON:libjson-c
   TITLE:=bind shared libraries
@@ -162,6 +161,14 @@ else
                --with-libxml2=no
 endif
 
+ifdef CONFIG_BIND_ENABLE_DOH
+       CONFIGURE_ARGS += \
+               --enable-doh
+else
+       CONFIGURE_ARGS += \
+               --disable-doh
+endif
+
 CONFIGURE_VARS += \
        BUILD_CC="$(TARGET_CC)" \