bash: fixing missing PARAMS() macro in strtod.c
authorPhilip Prindeville <philipp@redfish-solutions.com>
Tue, 2 Mar 2021 21:43:37 +0000 (14:43 -0700)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 19 Jan 2023 18:52:03 +0000 (19:52 +0100)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
(cherry picked from commit fd9012836aefc9abd6da8ee1c34119d193d3449d)

utils/bash/Makefile
utils/bash/patches/902-missing-params.patch [new file with mode: 0644]

index ca03b62853ca91bea71e54c921dbbb151bae6ffb..b15a145d457a45061d1578de0537ea9323a69662 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash
 PKG_VERSION:=5.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/bash
diff --git a/utils/bash/patches/902-missing-params.patch b/utils/bash/patches/902-missing-params.patch
new file mode 100644 (file)
index 0000000..45d3281
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/lib/sh/strtod.c
++++ b/lib/sh/strtod.c
+@@ -41,6 +41,8 @@ extern int errno;
+ #include <bashansi.h>
++#include <stdc.h>
++
+ #ifndef NULL
+ #  define NULL 0
+ #endif