python-qrcode: add Python3
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 3 Mar 2019 10:37:18 +0000 (11:37 +0100)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 5 Jul 2019 16:07:24 +0000 (18:07 +0200)
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
lang/python/python-qrcode/Makefile

index 54d333ce14900a6876f36e2e883335cb7f882a70..8bea796027003e46ac656c902d2d37df1c13bf4a 100644 (file)
@@ -9,28 +9,37 @@ PKG_NAME:=python-qrcode
 PKG_VERSION:=6.1
 PKG_RELEASE:=1
 
-PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-
 PKG_SOURCE:=qrcode-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/q/qrcode/
 PKG_HASH:=505253854f607f2abf4d16092c61d4e9d511a3b4392e60bff957a68592b04369
 
+PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILE:=LICENSE
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-qrcode-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
+include ../python3-package.mk
 
 PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
-define Package/python-qrcode
-  SUBMENU:=Python
+define Package/python-qrcode/Default
   SECTION:=lang
   CATEGORY:=Languages
+  SUBMENU:=Python
   TITLE:=QR Code image generator
   URL:=https://github.com/lincolnloop/python-qrcode
-  DEPENDS:=+python +python-six +python-setuptools +pillow
+endef
+
+define Package/python-qrcode
+$(call Package/python-qrcode/Default)
+  DEPENDS:= \
+       +PACKAGE_python-qrcode:python \
+       +PACKAGE_python-qrcode:python-setuptools \
+       +PACKAGE_python-qrcode:python-six \
+       +PACKAGE_python-qrcode:python-pillow
   VARIANT:=python
 endef
 
@@ -38,6 +47,26 @@ define Package/python-qrcode/description
   Pure python QR Code generator
 endef
 
+define Package/python3-qrcode
+$(call Package/python-qrcode/Default)
+  DEPENDS:= \
+       +PACKAGE_python3-qrcode:python3 \
+       +PACKAGE_python3-qrcode:python3-setuptools \
+       +PACKAGE_python3-qrcode:python3-six \
+       +PACKAGE_python3-qrcode:python3-pillow
+  VARIANT:=python3
+endef
+
+define Package/python3-qrcode/description
+$(call Package/python-qrcode/description)
+.
+(Variant for Python3)
+endef
+
 $(eval $(call PyPackage,python-qrcode))
 $(eval $(call BuildPackage,python-qrcode))
 $(eval $(call BuildPackage,python-qrcode-src))
+
+$(eval $(call Py3Package,python3-qrcode))
+$(eval $(call BuildPackage,python3-qrcode))
+$(eval $(call BuildPackage,python3-qrcode-src))