projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b1c0f54
)
selftests: gpio: override clean in lib.mk to fix warnings
author
Shuah Khan
<shuahkh@osg.samsung.com>
Fri, 21 Apr 2017 22:19:50 +0000
(16:19 -0600)
committer
Shuah Khan
<shuahkh@osg.samsung.com>
Tue, 25 Apr 2017 15:47:28 +0000
(09:47 -0600)
Add override for lib.mk clean to fix the following warnings from clean
target run.
Makefile:11: warning: overriding recipe for target 'clean'
../lib.mk:55: warning: ignoring old recipe for target 'clean'
Signed-off-by: Shuah Khan <shuahkh@osg.samsung.com>
tools/testing/selftests/gpio/Makefile
patch
|
blob
|
history
diff --git
a/tools/testing/selftests/gpio/Makefile
b/tools/testing/selftests/gpio/Makefile
index 205e4d10e0853c7b8d20342b21111a8693701834..4f6d9e0169b2d871fb3f0e8b2fec70c3a7bc18e9 100644
(file)
--- a/
tools/testing/selftests/gpio/Makefile
+++ b/
tools/testing/selftests/gpio/Makefile
@@
-7,8
+7,9
@@
include ../lib.mk
all: $(BINARIES)
-clean:
+override define CLEAN
$(RM) $(BINARIES)
+endef
CFLAGS += -O2 -g -std=gnu99 -Wall -I../../../../usr/include/
LDLIBS += -lmount -I/usr/include/libmount