adblock: reporting fixes/tweaks
authorDirk Brenken <dev@brenken.org>
Sun, 29 Nov 2020 07:46:28 +0000 (08:46 +0100)
committerDirk Brenken <dev@brenken.org>
Sun, 29 Nov 2020 07:46:28 +0000 (08:46 +0100)
* prevents the creation of an invalid json structure
* add more space to the domain column on cli

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/adblock/Makefile
net/adblock/files/adblock.sh

index e6068f7ca1679996c51faff434350f5688b10b09..4857d9b7a4e64a8069b5759a93cb4abf63d2f2e4 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
 PKG_VERSION:=4.0.7
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index d096cce2424306649ecd07d1a5490538b6e28482..55df0278f475e4cfbaba8e81c58ebd4c68a2a269 100755 (executable)
@@ -1486,8 +1486,8 @@ f_report()
                        do
                                (
                                        "${adb_dumpcmd}" -tttt -r "${file}" 2>/dev/null | \
-                                               "${adb_awk}" -v cnt="${cnt}" '!/\.lan\. |PTR\? | SOA\? /&&/ A[\? ]+|NXDomain|0\.0\.0\.0/{a=$1;b=substr($2,0,8);c=$4;sub(/\.[0-9]+$/,"",c);d=cnt $7;sub(/\*$/,"",d);
-                                               e=$(NF-1);sub(/[0-9]\/[0-9]\/[0-9]|0\.0\.0\.0/,"NX",e);sub(/\.$/,"",e);sub(/([0-9]{1,3}\.){3}[0-9]{1,3}/,"OK",e);if(e==""){e="err"};printf "%s\t%s\t%s\t%s\t%s\n",d,e,a,b,c}' >> "${adb_reportdir}/adb_report.raw"
+                                               "${adb_awk}" -v cnt="${cnt}" '!/\.lan\. |PTR\? | SOA\? /&&/ A[\? ]+|NXDomain|0\.0\.0\.0/{a=$1;b=substr($2,0,8);c=$4;sub(/\.[0-9]+$/,"",c);gsub(/[^[:alnum:]\.:-]/,"",c);d=cnt $7;sub(/\*$/,"",d);
+                                               e=$(NF-1);sub(/[0-9]\/[0-9]\/[0-9]|0\.0\.0\.0/,"NX",e);sub(/\.$/,"",e);sub(/([0-9]{1,3}\.){3}[0-9]{1,3}/,"OK",e);gsub(/[^[:alnum:]\.-]/,"",e);if(e==""){e="err"};printf "%s\t%s\t%s\t%s\t%s\n",d,e,a,b,c}' >> "${adb_reportdir}/adb_report.raw"
                                )&
                                hold=$((cnt%adb_maxqueue))
                                if [ "${hold}" -eq 0 ]
@@ -1593,13 +1593,13 @@ f_report()
                                        elif json_get_type status "${top}" && [ "${top}" = "requests" ] && [ "${status}" = "array" ]
                                        then
                                                printf "%s\\n%s\\n%s\\n" ":::" "::: Latest DNS Queries" ":::"
-                                               printf "%-15s%-15s%-45s%-50s%s\\n" "Date" "Time" "Client" "Domain" "Answer"
+                                               printf "%-15s%-15s%-45s%-80s%s\\n" "Date" "Time" "Client" "Domain" "Answer"
                                                json_select "${top}"
                                                index=1
                                                while json_get_type status "${index}" && [ "${status}" = "object" ]
                                                do
                                                        json_get_values item "${index}"
-                                                       printf "%-15s%-15s%-45s%-50s%s\\n" ${item}
+                                                       printf "%-15s%-15s%-45s%-80s%s\\n" ${item}
                                                        index=$((index+1))
                                                done
                                        fi