stress-ng: bump to version 0.12.10
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 24 May 2021 16:21:05 +0000 (19:21 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 14 Jun 2021 10:25:46 +0000 (13:25 +0300)
Patch `010-soft-float.patch` can be dropped.
It was upstreamed via https://github.com/ColinIanKing/stress-ng/pull/126

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
utils/stress-ng/Makefile
utils/stress-ng/patches/010-soft-float.patch [deleted file]

index fff45a7f164d3fbd2cfbce13fa56af43a55ec51d..646e74237e2cfc45489a581797017957e2ec17ba 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stress-ng
-PKG_VERSION:=0.12.07
+PKG_VERSION:=0.12.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://kernel.ubuntu.com/~cking/tarballs/stress-ng
-PKG_HASH:=cf73e3a4c7d95afa46aa27fb9283a8a988f3971de4ce6ffe9f651ca341731ead
+PKG_HASH:=bd167b6559fa8a28680371b1defd3ffe2344eb550129d58dd7d5e2d568f2786e
 
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
 PKG_LICENSE:=GPL-2.0-only
diff --git a/utils/stress-ng/patches/010-soft-float.patch b/utils/stress-ng/patches/010-soft-float.patch
deleted file mode 100644 (file)
index dd2dbec..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
---- a/stress-fp-error.c
-+++ b/stress-fp-error.c
-@@ -119,42 +119,43 @@ static int stress_fp_error(const stress_
-       do {
-               volatile double d1, d2;
--#if defined(EDOM)
-+#if defined(EDOM) && defined(FE_INVALID)
-               stress_fp_clear_error();
-               stress_fp_check(args, "log(-1.0)", log(-1.0), NAN,
-                       true, false, EDOM, FE_INVALID);
- #endif
--#if defined(ERANGE)
-+#if defined(ERANGE) && defined(FE_DIVBYZERO)
-               stress_fp_clear_error();
-               stress_fp_check(args, "log(0.0)", log(0.0), -HUGE_VAL,
-                       false, false, ERANGE, FE_DIVBYZERO);
- #endif
--#if defined(EDOM)
-+#if defined(EDOM) && defined(FE_INVALID)
-               stress_fp_clear_error();
-               stress_fp_check(args, "log2(-1.0)", log2(-1.0), NAN,
-                       true, false, EDOM, FE_INVALID);
- #endif
--#if defined(ERANGE)
-+#if defined(ERANGE) && defined(FE_DIVBYZERO)
-               stress_fp_clear_error();
-               stress_fp_check(args, "log2(0.0)", log2(0.0), -HUGE_VAL,
-                       false, false, ERANGE, FE_DIVBYZERO);
- #endif
--#if defined(EDOM)
-+#if defined(EDOM) && defined(FE_INVALID)
-               stress_fp_clear_error();
-               stress_fp_check(args, "sqrt(-1.0)", sqrt(-1.0), NAN,
-                       true, false, EDOM, FE_INVALID);
- #endif
--#if defined(EDOM)
-+#if defined(EDOM) && defined(FE_INVALID)
-               stress_fp_clear_error();
-               stress_fp_check(args, "sqrt(-1.0)", sqrt(-1.0), NAN,
-                       true, false, EDOM, FE_INVALID);
- #endif
-+#if defined(FE_INEXACT)
-               /*
-                * Use volatiles to force compiler to generate code
-                * to perform run time computation of 1.0 / M_PI
-@@ -175,14 +176,15 @@ static int stress_fp_error(const stress_
-               stress_fp_check(args, "DBL_MAX + DBL_MAX / 2.0",
-                       DBL_MAX + DBL_MAX / 2.0, INFINITY,
-                       false, true, 0, FE_OVERFLOW | FE_INEXACT);
-+#endif
--#if defined(ERANGE)
-+#if defined(ERANGE) && defined(FE_UNDERFLOW)
-               stress_fp_clear_error();
-               stress_fp_check(args, "exp(-1000000.0)", exp(-1000000.0), 0.0,
-                       false, false, ERANGE, FE_UNDERFLOW);
- #endif
--#if defined(ERANGE)
-+#if defined(ERANGE) && defined(FE_OVERFLOW)
-               stress_fp_clear_error();
-               stress_fp_check(args, "exp(DBL_MAX)", exp(DBL_MAX), HUGE_VAL,
-                       false, false, ERANGE, FE_OVERFLOW);