refresh patches and update to STABLE14 of squid
authorTim Yardley <lst@openwrt.org>
Wed, 25 Jul 2007 21:06:20 +0000 (21:06 +0000)
committerTim Yardley <lst@openwrt.org>
Wed, 25 Jul 2007 21:06:20 +0000 (21:06 +0000)
SVN-Revision: 8164

net/squid/Makefile
net/squid/patches/001-cross_compile.patch
net/squid/patches/002-no_sslv2.patch
net/squid/patches/003-configure.patch
net/squid/patches/004-include-autoconf.patch
net/squid/patches/005-lib-makefile.patch

index 0a655b73a37d5cd3abf3117a70fcb2c562254f8e..6e68545269b24a079279c4f6e552640c7af6b022 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.6.STABLE13
+PKG_VERSION:=2.6.STABLE14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
-PKG_MD5SUM:=fdc4ece264b47bab1b112d8f6f842b8b
+PKG_MD5SUM:=eadb138d48320df8b99349121159c6bf
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
index 4318707f928880db4733bb438ef3939e2f9f58a3..b73eeb8350987df66951e6726812c08bfc1ab316 100644 (file)
@@ -1,6 +1,7 @@
-diff -urN squid-2.5.STABLE13/src/ctype.c squid-2.5.STABLE13.new/src/ctype.c
---- squid-2.5.STABLE13/src/ctype.c     1970-01-01 01:00:00.000000000 +0100
-+++ squid-2.5.STABLE13.new/src/ctype.c 2006-04-15 10:29:39.000000000 +0200
+Index: squid-2.6.STABLE14/src/ctype.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ squid-2.6.STABLE14/src/ctype.c     2007-07-25 16:04:15.000000000 -0500
 @@ -0,0 +1,546 @@
 +/*
 + Static ctype data for IFC-7.1 / RedHat-9 workaround.
@@ -548,10 +549,11 @@ diff -urN squid-2.5.STABLE13/src/ctype.c squid-2.5.STABLE13.new/src/ctype.c
 +const uint32_t *__ctype32_tolower = b (uint32_t, tolower, 128);
 +const uint32_t *__ctype32_toupper = b (uint32_t, toupper, 128);
 +
-diff -urN squid-2.5.STABLE13/src/Makefile.in squid-2.5.STABLE13.new/src/Makefile.in
---- squid-2.5.STABLE13/src/Makefile.in 2005-09-28 22:57:21.000000000 +0200
-+++ squid-2.5.STABLE13.new/src/Makefile.in     2006-04-15 10:29:39.000000000 +0200
-@@ -1141,6 +1143,9 @@
+Index: squid-2.6.STABLE14/src/Makefile.in
+===================================================================
+--- squid-2.6.STABLE14.orig/src/Makefile.in    2007-07-25 16:04:15.000000000 -0500
++++ squid-2.6.STABLE14/src/Makefile.in 2007-07-25 16:04:15.000000000 -0500
+@@ -1219,6 +1219,9 @@
        $(SHELL) -c "test -f squid.conf.default || ./cf_gen cf.data"
  
  cf_parser.h: cf.data cf_gen$(EXEEXT)
index 823b5c620710aeea422a6e1158b2186b819ba3d4..ee940c97361bac17be5b19109186f0790d7f55b3 100644 (file)
@@ -1,8 +1,9 @@
-diff -ruN squid-2.5.STABLE14-old/src/ssl_support.c squid-2.5.STABLE14-new/src/ssl_support.c
---- squid-2.5.STABLE14-old/src/ssl_support.c   2003-12-11 08:53:11.000000000 +0100
-+++ squid-2.5.STABLE14-new/src/ssl_support.c   2006-12-17 18:23:57.000000000 +0100
-@@ -291,10 +291,12 @@
+Index: squid-2.6.STABLE14/src/ssl_support.c
+===================================================================
+--- squid-2.6.STABLE14.orig/src/ssl_support.c  2007-07-25 16:04:15.000000000 -0500
++++ squid-2.6.STABLE14/src/ssl_support.c       2007-07-25 16:04:15.000000000 -0500
+@@ -442,10 +442,12 @@
+     ERR_clear_error();
      debug(83, 1) ("Initialising SSL.\n");
      switch (version) {
 +#ifndef OPENSSL_NO_SSL2
index 9901bcc9f36c8e4739368aee41d4552807192a09..8683e11c387bb166627ff4faaaa8111ca6547cae 100644 (file)
@@ -1,6 +1,8 @@
---- squid-2.6.STABLE12/configure       2007-03-20 16:35:44.000000000 -0500
-+++ squid-2.6.STABLE12.NEW/configure   2007-04-08 11:49:42.000000000 -0500
-@@ -4297,10 +4297,6 @@
+Index: squid-2.6.STABLE14/configure
+===================================================================
+--- squid-2.6.STABLE14.orig/configure  2007-07-25 16:04:15.000000000 -0500
++++ squid-2.6.STABLE14/configure       2007-07-25 16:04:16.000000000 -0500
+@@ -4298,10 +4298,6 @@
    if test -z "$SSLLIB"; then
      SSLLIB="-lcrypto" # for MD5 routines
    fi
@@ -11,7 +13,7 @@
    CPPFLAGS="${SSLFLAGS} $CPPFLAGS"
  fi
  
-@@ -8760,7 +8756,7 @@
+@@ -8780,7 +8776,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -20,7 +22,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -9174,7 +9170,7 @@
+@@ -9194,7 +9190,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -29,7 +31,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -9588,7 +9584,7 @@
+@@ -9608,7 +9604,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -38,7 +40,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10002,7 +9998,7 @@
+@@ -10022,7 +10018,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -47,7 +49,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10416,7 +10412,7 @@
+@@ -10436,7 +10432,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -56,7 +58,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10830,7 +10826,7 @@
+@@ -10850,7 +10846,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -65,7 +67,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10919,7 +10915,7 @@
+@@ -11361,7 +11357,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -74,7 +76,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10992,7 +10988,7 @@
+@@ -11889,7 +11885,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -83,7 +85,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11065,7 +11061,7 @@
+@@ -12417,7 +12413,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -92,7 +94,7 @@
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11138,7 +11134,7 @@
+@@ -12945,7 +12941,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11211,7 +11207,7 @@
+@@ -13473,7 +13469,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11284,7 +11280,7 @@
+@@ -14001,7 +13997,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11357,7 +11353,7 @@
+@@ -14529,7 +14525,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11430,7 +11426,7 @@
+@@ -15057,7 +15053,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11503,7 +11499,7 @@
+@@ -15585,7 +15581,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11576,7 +11572,7 @@
+@@ -16113,7 +16109,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11649,7 +11645,7 @@
+@@ -16641,7 +16637,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11722,7 +11718,7 @@
+@@ -17169,7 +17165,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -11795,7 +11791,7 @@
+@@ -17697,7 +17693,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -16302,7 +16298,7 @@
+@@ -22106,7 +22102,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -16455,7 +16451,7 @@
+@@ -24523,7 +24519,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -16577,7 +16573,7 @@
+@@ -24687,7 +24683,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -16686,7 +16682,7 @@
+@@ -24809,7 +24805,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -16754,7 +16750,7 @@
+@@ -24918,7 +24914,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
index 4539c28602dc4da05eecd35b50ec17c043de24a4..676cb984ebc5cc5e6ce1dc9dbd03dea6b1e9a016 100644 (file)
@@ -1,5 +1,7 @@
---- squid-2.6.STABLE12/include/autoconf.h.in.orig      2007-03-12 21:36:39.000000000 -0500
-+++ squid-2.6.STABLE12/include/autoconf.h.in   2007-04-07 20:12:28.000000000 -0500
+Index: squid-2.6.STABLE14/include/autoconf.h.in
+===================================================================
+--- squid-2.6.STABLE14.orig/include/autoconf.h.in      2007-07-25 16:04:15.000000000 -0500
++++ squid-2.6.STABLE14/include/autoconf.h.in   2007-07-25 16:04:16.000000000 -0500
 @@ -319,10 +319,10 @@
  #undef HAVE_OPENSSL_ERR_H
  
index 52cb6eb3a1a9046d7d52189aff2a76238c68c12a..e026184e108f8aefb55e72c05d28bf65d08e97c0 100644 (file)
@@ -1,5 +1,7 @@
---- squid-2.6.STABLE12/lib/Makefile.in.orig    2006-11-04 17:20:02.000000000 -0600
-+++ squid-2.6.STABLE12/lib/Makefile.in 2007-04-07 20:26:04.000000000 -0500
+Index: squid-2.6.STABLE14/lib/Makefile.in
+===================================================================
+--- squid-2.6.STABLE14.orig/lib/Makefile.in    2007-07-25 16:04:15.000000000 -0500
++++ squid-2.6.STABLE14/lib/Makefile.in 2007-07-25 16:04:16.000000000 -0500
 @@ -65,7 +65,9 @@
        splay.c Stack.c strsep.c stub_memaccount.c util.c uudecode.c \
        win32lib.c
@@ -77,7 +79,7 @@
  OPT_DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
  PACKAGE = @PACKAGE@
  PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
-@@ -301,6 +323,7 @@
+@@ -303,6 +325,7 @@
  noinst_LIBRARIES = \
        @LIBDLMALLOC@ \
        libmiscutil.a \
@@ -85,7 +87,7 @@
        libntlmauth.a \
        @LIBREGEX@ \
        $(LIBSSPWIN32)
-@@ -335,9 +358,34 @@
+@@ -337,9 +360,34 @@
        uudecode.c \
        $(WIN32SRC)
  
  # $(top_srcdir)/include/version.h should be a dependency
  libregex_a_SOURCES = \
        GNUregex.c
-@@ -358,7 +406,7 @@
+@@ -360,7 +408,7 @@
  all: all-am
  
  .SUFFIXES:
  $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am  $(am__configure_deps)
        @for dep in $?; do \
          case '$(am__configure_deps)' in \
-@@ -395,10 +443,13 @@
+@@ -397,10 +445,13 @@
        -rm -f libdlmalloc.a
        $(libdlmalloc_a_AR) libdlmalloc.a $(libdlmalloc_a_OBJECTS) $(libdlmalloc_a_LIBADD)
        $(RANLIB) libdlmalloc.a
  libntlmauth.a: $(libntlmauth_a_OBJECTS) $(libntlmauth_a_DEPENDENCIES) 
        -rm -f libntlmauth.a
        $(libntlmauth_a_AR) libntlmauth.a $(libntlmauth_a_OBJECTS) $(libntlmauth_a_LIBADD)
-@@ -449,6 +500,21 @@
+@@ -451,6 +502,21 @@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/util.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uudecode.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/win32lib.Po@am__quote@
  
  .c.o:
  @am__fastdepCC_TRUE@  if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
-@@ -457,6 +523,9 @@
+@@ -459,6 +525,9 @@
  @AMDEP_TRUE@@am__fastdepCC_FALSE@     DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
  @am__fastdepCC_FALSE@ $(COMPILE) -c $<