knot-resolver: update to version 5.5.1
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 22 Jun 2022 15:00:02 +0000 (17:00 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 23 Jun 2022 18:14:28 +0000 (20:14 +0200)
Changelog for versions:
- 5.4.4 [1]
- 5.5.0 [2]
- 5.5.1 [3]

[1] https://www.knot-resolver.cz/2022-01-05-knot-resolver-5.4.4.html
[2] https://www.knot-resolver.cz/2022-03-15-knot-resolver-5.5.0.html
[3] https://www.knot-resolver.cz/2022-06-14-knot-resolver-5.5.1.html

And refresh patch to avoid offset

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit f74754fac189d7315db3b615da2afc8c95e920bb)

net/knot-resolver/Makefile
net/knot-resolver/patches/030-fix-policy-hack.patch

index 8e79db2a4587d3d050460f284a75814da8bb6d87..011c890fd04ca47b0625bfcc115b0c664348220c 100644 (file)
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=knot-resolver
-PKG_VERSION:=5.4.3
+PKG_VERSION:=5.5.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=488729eb93190336b6bca10de0d78ecb7919f77fcab105debc0a644aa7d0a506
+PKG_HASH:=9bad1edfd6631446da2d2331bd869887d7fe502f6eeaf62b2e43e2c113f02b6d
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
 PKG_LICENSE:=GPL-3.0-later
index 991dddd96977c84c3f1da4b9aa54f80026052cc2..70c6f81b064e68ba29cff47249f4dea0fb5e51eb 100644 (file)
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
 It reintroduces a fix which enables  policy related hack (knot/knot-resolver#205 (comment 94566) )
 --- a/modules/policy/policy.lua
 +++ b/modules/policy/policy.lua
-@@ -1047,7 +1047,7 @@ policy.layer = {
+@@ -1098,7 +1098,7 @@ policy.layer = {
                if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
                local qry = req:initial() -- same as :current() but more descriptive
                return policy.evaluate(policy.rules, req, qry, state)