django-ranged-response: update packaging format + add python3 variant
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 3 Jul 2019 08:23:46 +0000 (11:23 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 11 Jul 2019 12:15:23 +0000 (15:15 +0300)
This change also updates the maintainer email to cotequeiroz@gmail.com, as
requested on a different change.

Not updating deps here, since that will be done in the next changeset that
will convert packages to the Python[3] packaging format.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/django-ranged-response/Makefile

index 09d1579264d48edb4fda3be2ae47458cfcc999c2..818530f5992b4401c9d3a2e8715bda5eae58e77b 100644 (file)
@@ -7,32 +7,62 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=django-ranged-response
 PKG_VERSION:=0.2.0
-PKG_RELEASE:=4
-
-PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
-PKG_LICENSE:=MIT
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/d/${PKG_NAME}
 PKG_HASH:=f71fff352a37316b9bead717fc76e4ddd6c9b99c4680cdf4783b9755af1cf985
 
+PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
-define Package/django-ranged-response
+define Package/$(PKG_NAME)/Default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Add Content-Range: to FileResponse
   URL:=https://github.com/wearespindle/django-ranged-fileresponse
-  DEPENDS:=+python +python-django
+endef
+
+define Package/python-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python-$(PKG_NAME):python \
+       +PACKAGE_python-$(PKG_NAME):python-django
   VARIANT:=python
 endef
 
-define Package/django-ranged-response/description
+define Package/python-$(PKG_NAME)/description
   Modified Django FileResponse that adds Content-Range headers.
 endef
 
-$(eval $(call PyPackage,django-ranged-response))
-$(eval $(call BuildPackage,django-ranged-response))
-$(eval $(call BuildPackage,django-ranged-response-src))
+define Package/python3-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python3-$(PKG_NAME):python3 \
+       +PACKAGE_python3-$(PKG_NAME):python3-django
+  VARIANT:=python3
+endef
+
+define Package/python3-$(PKG_NAME)/description
+$(call define Package/python-$(PKG_NAME)/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)-src))
+
+$(eval $(call Py3Package,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)-src))