python,python3: do not package binary files to base packages
authorKarel Kočí <karel.koci@nic.cz>
Wed, 20 Feb 2019 11:51:05 +0000 (12:51 +0100)
committerKarel Kočí <karel.koci@nic.cz>
Thu, 21 Feb 2019 08:33:49 +0000 (09:33 +0100)
Thanks to fix 200a5a2eec896b2d34f1114d14df66d810c1f4bd all base packages
now contain all binaries that are generated as part of python
installation. That causes collision between those packages with package
managers that consider this such as Turris updater-ng. This is also just
wrong. Those binaries were not included and should not be after
mentioned fix as well.

This just adds empty install definition. The idea is to override the
default one that is otherwise used.

Signed-off-by: Karel Kočí <karel.koci@nic.cz>
lang/python/python/Makefile
lang/python/python3/Makefile

index 041b3028c9faa698455eee760dfd095913d4f911..c4b11837c2291a85bda068e13fad3bd447f72354 100644 (file)
@@ -106,6 +106,7 @@ define PyBasePackage
       -|/usr/lib/python$(PYTHON_VERSION)/*/tests
     endif
   endef
+  PyPackage/$(1)/install?=:
 endef
 
 include ./files/python-package-*.mk
@@ -263,6 +264,9 @@ define PyPackage/python-base/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
 endef
 
+PyPackage/python-light/install:=:
+PyPackage/python/install:=:
+
 define PyPackage/python/filespec
 -|$(PYTHON_PKG_DIR)
 endef
index a88b8165cc83a8d1afcb417e43ed00aacaedbb70..872f654b8d59263a3aef0845429eed34854e2177 100644 (file)
@@ -110,6 +110,7 @@ define Py3BasePackage
       -|/usr/lib/python$(PYTHON_VERSION)/*/tests
     endif
   endef
+  Py3Package/$(1)/install?=:
 endef
 
 include ./files/python3-package-*.mk
@@ -264,6 +265,9 @@ define Py3Package/python3-base/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
 endef
 
+Py3Package/python3-light/install:=:
+Py3Package/python3/install:=:
+
 define Py3Package/python3/filespec
 -|$(PYTHON3_PKG_DIR)
 endef