ramips: use new image build code for D-Link DCS-930 family
authorMathias Kresin <dev@kresin.me>
Thu, 29 Nov 2018 22:40:12 +0000 (23:40 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 12 Dec 2018 10:01:59 +0000 (11:01 +0100)
Drop the factory images and the firmware tool to create them. They don't
work any more, since the factory image has an uImage header covering the
whole kernel + rootfs. This way the uImage splitter will not be able to
find the rootfs and the kernel will panic later on.

The factory images were most likely added at a time the board had
distinct partitions for kernel and rootfs.

Signed-off-by: Mathias Kresin <dev@kresin.me>
Makefile
src/mkdcs932.c [deleted file]

index 00917c34178c7a1a8d5300a42ad03011e97d3778..63df63191df137e9838c314c185b45dea5f5ae74 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -72,7 +72,6 @@ define Host/Compile
        $(call cc,mkporayfw, -Wall)
        $(call cc,mkrasimage, --std=gnu99)
        $(call cc,mkhilinkfw, -lcrypto)
-       $(call cc,mkdcs932, -Wall)
        $(call cc,mkheader_gemtek,-lz)
        $(call cc,mkrtn56uimg, -lz)
        $(call cc,dgn3500sum, -Wall)
diff --git a/src/mkdcs932.c b/src/mkdcs932.c
deleted file mode 100644 (file)
index 28c67aa..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-/*
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License,
- * version 2 as published by the Free Software Foundation.
- *
- * (C) John Crispin <blogic@openwrt.org>
- */
-
-#include <sys/types.h>
-#include <sys/stat.h>
-#include <fcntl.h>
-#include <stdio.h>
-#include <stdint.h>
-#include <unistd.h>
-#include <errno.h>
-
-int main(int argc, char **argv)
-{
-       uint32_t t = 0, sum = 0x55aa55aa;
-       int fd;
-
-       if ((argc != 2) || ((fd = open(argv[1], O_RDWR)) == -1)) {
-               fprintf(stderr, "Usage: %s input_file\n", *argv);
-               return -EINVAL;
-       }
-
-       lseek(fd, -4, SEEK_END);
-       write(fd, &t, 4);
-       lseek(fd, 0, SEEK_SET);
-
-       while (read(fd, &t, 4) > 0)
-               sum -= t;
-
-       lseek(fd, -4, SEEK_END);
-       write(fd, &sum, 4);
-       close(fd);
-
-       return 0;
-}