fix inclusion of kernel modules selected for install in images (closes: #598).
authorNicolas Thill <nico@openwrt.org>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
SVN-Revision: 4081

openwrt/target/linux/rules.mk

index 5ba43deea0efc703e93da12d3d5441970b50562a..9b44c2568c936a3d695cba78c12e22288a586874 100644 (file)
@@ -18,10 +18,10 @@ PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(
 I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)
 
 ifeq ($$(KDEPEND_$(1)),m)
-ifneq ($(BR2_PACKAGE_KMOD_$(1)),)
+ifneq ($$(BR2_PACKAGE_KMOD_$(1)),)
 TARGETS += $$(PKG_$(1))
 endif
-ifeq ($(BR2_PACKAGE_KMOD_$(1)),y)
+ifeq ($$(BR2_PACKAGE_KMOD_$(1)),y)
 INSTALL_TARGETS += $$(PKG_$(1))
 endif
 endif