modemmanager: avoid requiring autoreconf to build package
authorAleksander Morgado <aleksander@aleksander.es>
Tue, 28 Jul 2020 13:51:42 +0000 (15:51 +0200)
committerAleksander Morgado <aleksander@aleksander.es>
Thu, 30 Jul 2020 07:32:17 +0000 (09:32 +0200)
Do not manually overwrite the paths of gdbus-codegen or glib-mkenums
in the ModemManager package build, as modifying the configure.ac ends
up requiring a full autoreconf.

Since MM 1.14, git builds or autoreconf-ed source package builds
require autoconf-archive installed in the build system, and so the
build would fail if this happens.

The update to overwrite the paths was to force using the gdbus-codegen
and glib-mkenums provided by the "host" glib2 package instead of the
"target" glib2 package (see fa8ad6e69c41d694b1220e04ec4f45bb8e8c1edf),
but these tools are really the same in both as they're python
programs, arch independent.

Tested in a local build where the setup detects and uses the correct
glib tool paths from the target:
  /home/user/openwrt/staging_dir/target-mips_24kc_musl/usr/bin/gdbus-codegen
  /home/user/openwrt/staging_dir/target-mips_24kc_musl/usr/bin/glib-mkenums

Fixes https://github.com/openwrt/packages/issues/12958

Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>
net/modemmanager/Makefile

index 9f1d33317170091f296e3fa6c42bf476e67923f9..17ce05849bf5b8e19af41131279920c3a8acae77 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=modemmanager
 PKG_VERSION:=1.14.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=ModemManager-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.freedesktop.org/software/ModemManager
@@ -20,10 +20,9 @@ PKG_MAINTAINER:=Nicholas Smith <nicholas.smith@telcoantennas.com.au>
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
 
-PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
-PKG_BUILD_DEPENDS:=glib2/host libxslt/host
+PKG_BUILD_DEPENDS:=libxslt/host
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
@@ -76,10 +75,6 @@ define Build/Prepare
        ( cd "$(PKG_BUILD_DIR)"; \
                printf "all:\ninstall:\n" >po/Makefile.in.in; \
        )
-       $(SED) 's|^\(GLIB_MKENUMS\)=.*|\1=$(STAGING_DIR_HOSTPKG)/bin/glib-mkenums|' \
-               $(PKG_BUILD_DIR)/configure.ac
-       $(SED) 's|^\(GDBUS_CODEGEN\)=.*|\1=$(STAGING_DIR_HOSTPKG)/bin/gdbus-codegen|' \
-               $(PKG_BUILD_DIR)/configure.ac
 endef
 
 define Build/InstallDev