netfilter: fix bogus reference to `kmod-nf-conntrack-timeout`
authorJoel Low <joel@joelsplace.sg>
Fri, 27 Dec 2024 00:13:26 +0000 (08:13 +0800)
committerRobert Marko <robimarko@gmail.com>
Fri, 27 Dec 2024 15:10:21 +0000 (16:10 +0100)
Fix bogus reference to kmod-nf-conntrack-timeout, fixing the warning
`WARNING: Makefile 'package/kernel/linux/Makefile' has a dependency on
'kmod-nf-conntrack-timeout', which does not exist`.

Fixes: 0e2dcfc4f488 ("netfilter: add kmod-nfnetlink-ct{helper,timeout}")
Signed-off-by: Joel Low <joel@joelsplace.sg>
Link: https://github.com/openwrt/openwrt/pull/17388
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/linux/modules/netfilter.mk

index 30ff35ca6bf211d61fdf81e53c59361ac574a83d..96531b1e0803a794ba25a71a98159b4ee8034422 100644 (file)
@@ -1069,7 +1069,7 @@ define KernelPackage/nfnetlink-cttimeout
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_cttimeout.ko
   KCONFIG:=CONFIG_NF_CT_NETLINK_TIMEOUT
   AUTOLOAD:=$(call AutoProbe,nfnetlink_cttimeout)
-  $(call AddDepends/nfnetlink,+kmod-nf-conntrack +kmod-nf-conntrack-timeout @KERNEL_NF_CONNTRACK_TIMEOUT)
+  $(call AddDepends/nfnetlink,+kmod-nf-conntrack @KERNEL_NF_CONNTRACK_TIMEOUT)
 endef
 
 define KernelPackage/nfnetlink-cttimeout/description