measurement-kit: update to version 0.10.8
authorJan Pavlinec <jan.pavlinec@nic.cz>
Thu, 9 Jan 2020 00:22:26 +0000 (01:22 +0100)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Thu, 9 Jan 2020 00:22:43 +0000 (01:22 +0100)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
libs/measurement-kit/Makefile
libs/measurement-kit/patches/001-remove-ca-download.patch [deleted file]
libs/measurement-kit/patches/002-replace-curl-with-wget.patch [deleted file]

index c074dcb137158834aa80ec6fe4d74ec7d49be0d6..fd1890f57b4d3f722a193b00a8e844881e97b0fc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+# Copyright (C) 2019-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=measurement-kit
-PKG_VERSION:=0.10.6
-PKG_RELEASE:=2
+PKG_VERSION:=0.10.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/measurement-kit/measurement-kit/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=5ec94e522c3bc43cbf749659c18d4b13bcfbb2874db4d6b4e21b160d76dd5bd0
+PKG_HASH:=773c0f03fa21b56b34a24f97b4fedf96e66b0f49ef549d5c674e63ed43e1c278
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=BSD-2-Clause
@@ -40,7 +40,7 @@ endef
 CONFIGURE_ARGS+= --with-ca-bundle=/etc/ssl/cert.pem
 
 define Build/Configure
-       ( cd $(PKG_BUILD_DIR); ./autogen.sh )
+       ( cd $(PKG_BUILD_DIR); ./autogen.sh --no-geoip)
        $(call Build/Configure/Default)
 endef
 
diff --git a/libs/measurement-kit/patches/001-remove-ca-download.patch b/libs/measurement-kit/patches/001-remove-ca-download.patch
deleted file mode 100644 (file)
index b3b9ecc..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/autogen.sh
-+++ b/autogen.sh
-@@ -3,7 +3,7 @@
- set -e
- export LC_ALL=C  # Stable sorting regardless of the locale
-
--. script/autogen.d/ca-bundle
-+#. script/autogen.d/ca-bundle
- . script/autogen.d/geoip
-
- no_geoip=0
-@@ -82,7 +82,7 @@ gen_executables noinst_PROGRAMS example
- gen_executables ALL_TESTS test libtest_main.la                   >> include.am
-
- if [ $no_geoip -ne 1 ]; then
--    autogen_get_ca_bundle
-+    #autogen_get_ca_bundle
-     autogen_get_geoip
- fi
-
diff --git a/libs/measurement-kit/patches/002-replace-curl-with-wget.patch b/libs/measurement-kit/patches/002-replace-curl-with-wget.patch
deleted file mode 100644 (file)
index c7d7112..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/script/autogen.d/geoip
-+++ b/script/autogen.d/geoip
-@@ -5,13 +5,13 @@ autogen_get_geoip() {
-     echo "* Fetching geoip databases"
-     base=https://geolite.maxmind.com/download/geoip/database
-     if [ ! -f "country.mmdb" ]; then
--        curl -fsSLO $base/GeoLite2-Country.tar.gz
-+        command -v curl && curl -fsSLO $base/GeoLite2-Country.tar.gz || wget $base/GeoLite2-Country.tar.gz
-         tar -xf GeoLite2-Country.tar.gz
-         mv GeoLite2-Country_20??????/GeoLite2-Country.mmdb country.mmdb
-         rm -rf GeoLite2-Country_20??????
-     fi
-     if [ ! -f "asn.mmdb" ]; then
--        curl -fsSLO $base/GeoLite2-ASN.tar.gz
-+        command -v curl && curl -fsSLO $base/GeoLite2-ASN.tar.gz || wget $base/GeoLite2-ASN.tar.gz
-         tar -xf GeoLite2-ASN.tar.gz
-         mv GeoLite2-ASN_20??????/GeoLite2-ASN.mmdb asn.mmdb
-         rm -rf GeoLite2-ASN_20??????