kbuild: remove user ID check in scripts/mkmakefile
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Tue, 18 Sep 2018 08:45:52 +0000 (17:45 +0900)
committerMasahiro Yamada <yamada.masahiro@socionext.com>
Thu, 4 Oct 2018 13:56:02 +0000 (22:56 +0900)
This line was added by commit fd5f0cd6b0ce ("kbuild: Do not overwrite
makefile as anohter user").  Its commit description says the intention
was to prevent $(objtree)/Makefile from being owned by root when e.g.
running 'make install'.

However, as commit 19514fc665ff ("arm, kbuild: make "make install" not
depend on vmlinux") stated, installation targets must not modify the
source tree in the first place.  If they do, we are already screwed up.
We must fix the root cause.

Installation targets should just copy files verbatim, hence we never
expect $(objtree)/Makefile is touched by root.  The user ID check in
scripts/mkmakefile is unneeded.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
scripts/mkmakefile

index e21064445085f4445cc4baa3a147e34d5ed1f91f..24354284d4add8489ee4e396e503d2b9df0d0ae4 100755 (executable)
@@ -8,7 +8,6 @@
 # $1 - Kernel src directory
 # $2 - Output directory
 
-test ! -r $2/Makefile -o -O $2/Makefile || exit 0
 # Only overwrite automatically generated Makefiles
 # (so we do not overwrite kernel Makefile)
 if test -e $2/Makefile && ! grep -q Automatically $2/Makefile