python-zope-interface: Update to 5.0.1, refresh patch
authorJeffery To <jeffery.to@gmail.com>
Mon, 23 Mar 2020 17:18:33 +0000 (01:18 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 23 Mar 2020 17:18:33 +0000 (01:18 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-zope-interface/Makefile
lang/python/python-zope-interface/patches/001-omit-tests.patch

index a9e36d2914b7629dbba25613ed01b6b309bc15ae..06bda5718585351f0b3f8bbc729f4e64f07fe1b7 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-zope-interface
-PKG_VERSION:=4.7.2
+PKG_VERSION:=5.0.1
 PKG_RELEASE:=1
 
 PYPI_NAME:=zope.interface
-PKG_HASH:=fd1101bd3fcb4f4cf3485bb20d6cb0b56909b94d3bd2a53a6cb9d381c3da3365
+PKG_HASH:=dd0bc4016ec9ffa6d327bf3ba2f044c3ff376880661e5cc38c622e1ae023076f
 
 PKG_LICENSE:=ZPL-2.1
 PKG_LICENSE_FILES:=LICENSE.txt
index 6c9e679af66ec94b9504edf9758586a3bfebe8a3..40aed6e2bff3b8840aec5a4927b891f5376db180 100644 (file)
@@ -1,15 +1,15 @@
 --- a/setup.py
 +++ b/setup.py
-@@ -121,7 +121,7 @@ setup(name='zope.interface',
-         "Framework :: Zope :: 3",
-         "Topic :: Software Development :: Libraries :: Python Modules",
+@@ -125,7 +125,7 @@ setup(name='zope.interface',
+           "Framework :: Zope :: 3",
+           "Topic :: Software Development :: Libraries :: Python Modules",
        ],
 -      packages=find_packages('src'),
 +      packages=find_packages('src', exclude=["*.tests", "*.tests.*"]),
        package_dir={'': 'src'},
        namespace_packages=["zope"],
        cmdclass={
-@@ -129,6 +129,7 @@ setup(name='zope.interface',
+@@ -133,6 +133,7 @@ setup(name='zope.interface',
        },
        test_suite='zope.interface.tests',
        include_package_data=True,