pps-tools: update package, allow compiling on more recent kernels
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 21 Sep 2014 15:25:27 +0000 (17:25 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 21 Sep 2014 15:25:27 +0000 (17:25 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
utils/pps-tools/Makefile [new file with mode: 0644]

diff --git a/utils/pps-tools/Makefile b/utils/pps-tools/Makefile
new file mode 100644 (file)
index 0000000..93d0578
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pps-tools
+PKG_VERSION:=2014-08-01
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://github.com/ago/pps-tools
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=0deb9c7e135e9380a6d09e9d2e938a146bb698c8
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+PKG_MAINTAINER := Zoltan HERPAI <wigyori@uid0.hu>
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pps-tools
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=PPS-tools
+  DEPENDS:=@LINUX_3_10||@LINUX_3_13||@LINUX_3_14
+endef
+
+define Package/pps-tools/description
+  Userland tools for GPS and DCF-77 Clock syncronization. PPS support in Kernel must be enabled.
+endef
+
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/
+endef
+
+define Package/pps-tools/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ppsctl $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ppstest $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ppswatch $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,pps-tools))