python-exceptiongroup: Remove previous build workaround
authorJeffery To <jeffery.to@gmail.com>
Thu, 13 Apr 2023 17:36:12 +0000 (01:36 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 24 Apr 2023 08:20:34 +0000 (16:20 +0800)
With proper support for pyproject.toml-based builds in place, this is no
longer necessary.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-exceptiongroup/Makefile
lang/python/python-exceptiongroup/patches/0001-add-setup.py-to-avoid-depending-on-flit-for-building.patch [deleted file]

index 4cde0a6c5386624d1c6a324ce1a87d9db0e4cd9e..80be44b2ef3b72c18bf9968c8c63ca863d6ec649 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-exceptiongroup
 PKG_VERSION:=1.1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=exceptiongroup
 PKG_HASH:=d484c3090ba2889ae2928419117447a14daf3c1231d5e30d0aae34f354f01785
diff --git a/lang/python/python-exceptiongroup/patches/0001-add-setup.py-to-avoid-depending-on-flit-for-building.patch b/lang/python/python-exceptiongroup/patches/0001-add-setup.py-to-avoid-depending-on-flit-for-building.patch
deleted file mode 100644 (file)
index aca11e3..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From d6a0c3045598597023ee2423144b134fc87f4b6f Mon Sep 17 00:00:00 2001
-From: Julien Malik <julien.malik@paraiso.me>
-Date: Sat, 26 Nov 2022 13:05:20 +0100
-Subject: [PATCH] add setup.py to avoid depending on flit for building
-
----
- setup.py | 18 ++++++++++++++++++
- 1 file changed, 18 insertions(+)
- create mode 100644 setup.py
-
---- /dev/null
-+++ b/setup.py
-@@ -0,0 +1,18 @@
-+#!/usr/bin/env python
-+
-+import setuptools
-+
-+setuptools.setup(
-+      name='exceptiongroup',
-+      version='1.1.1',
-+      description='Backport of PEP 654 (exception groups)',
-+      author='Alex Grönholm',
-+      author_email='Alex Grönholm <alex.gronholm@nextday.fi>',
-+      url='https://github.com/agronholm/exceptiongroup',
-+      packages=['exceptiongroup'],
-+      package_data={'': ['*']},
-+      package_dir={'': 'src'},
-+      extras_require={'test': ['pytest >= 6']},
-+      python_requires='>=3.7',
-+)
-+