Use this new PyMod template
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 12:42:11 +0000 (12:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 12:42:11 +0000 (12:42 +0000)
SVN-Revision: 8523

lang/kid/Makefile
libs/pyevent/Makefile
net/pypcap/Makefile

index bf12535eee03f846513c8a8a2a16705a696cff42..936f3417d8cc264b5113c1693d0acda1d9800289 100644 (file)
@@ -25,11 +25,7 @@ define Package/kid
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR); \
-       CFLAGS='-I$(STAGING_DIR)/usr/include' \
-       LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
-       $(STAGING_DIR)/usr/bin/hostpython ./setup.py install \
-       --prefix=$(PKG_INSTALL_DIR)/usr
+       $(call Build/Compile/PyMod,,install)
 endef
 
 define Package/kid/install
index 8a0896e1ee5e7e5c53c304894210ccffc41a86aa..251fc4e81ddcb238cdf9bf51d9c997087dce6c0b 100644 (file)
@@ -26,12 +26,11 @@ define Package/pyevent
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR); \
-       LIBEVENT_HOME='$(STAGING_DIR)/usr/lib' \
-       CFLAGS='-I$(STAGING_DIR)/usr/include' \
-       LDFLAGS='$(TARGET_LDFLAGS)' \
-       $(STAGING_DIR)/usr/bin/hostpython ./setup.py install \
-       --prefix=$(PKG_INSTALL_DIR)/usr
+       $(call Build/Compile/PyMod,\
+               LIBEVENT_HOME='$(STAGING_DIR)/usr/lib' \
+               ,\
+               install \
+       )
 endef
 
 define Package/pyevent/install
index 84c5fccdb1ca9e4fa77f6577c43ba0312b1c06ab..f4d7642d5c27fd7007953f0f8b23b21bc90efa38 100644 (file)
@@ -24,9 +24,11 @@ define Package/pypcap
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR); \
-       PCAP_HOME=$(STAGING_DIR)/usr \
-       $(STAGING_DIR)/usr/bin/hostpython ./setup.py build
+       $(call Build/Compile/PyMod,\
+               PCAP_HOME=$(STAGING_DIR)/usr \
+               ,\
+               install \
+       )
 endef
 
 define Package/pypcap/install