perl: update to 5.26.2
authorPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 29 Apr 2018 21:07:15 +0000 (15:07 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 29 Apr 2018 22:18:14 +0000 (16:18 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
lang/perl/Makefile
lang/perl/files/version.config
lang/perl/patches/010-musl-compat.patch
lang/perl/patches/120-remove-build-timestamp.patch
lang/perl/patches/910-miniperl-needs-inc-dot.patch

index b6111aad4e8e64452953274c01f3072fbe31410b..81c5e71db8df83dc19fc701a0a12d88c9ea0c81e 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=perl
-PKG_VERSION:=5.26.1
-PKG_RELEASE:=3
+PKG_VERSION:=5.26.2
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=\
                https://cpan.metacpan.org/src/5.0 \
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=\
                https://mirrors.sonic.net/cpan/src/5.0 \
                https://www.cpan.org/src/5.0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=fe8208133e73e47afc3251c08d2c21c5a60160165a8ab8b669c43a420e4ec680
+PKG_HASH:=0f8c0fb1b0db4681adb75c3ba0dd77a0472b1b359b9e80efd79fc27b4352132c
 
 PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
 PKG_LICENSE_FILES:=Copying Artistic README
index c8ebd4c649ea1a928b06288b255fd5cd05ce6d50..9bf885552e221f249c1884ecaf5a098f006c1d69 100644 (file)
@@ -1,7 +1,7 @@
 # Set the version here
 PERL_REVISION=5
 PERL_VERSION=26
-PERL_SUBVERSION=1
+PERL_SUBVERSION=2
 
 # (api_revison, api_version, api_subversion) = (revision, version, 0) usually
 PERL_API_REVISION=5
index 8dbad78f4ce4ba55e975f6b88b9e0ad481fa3e8d..c1479ff2f04019edcf4d7b89dee725d38419cb0d 100644 (file)
@@ -1,11 +1,11 @@
---- a/pp.c
-+++ b/pp.c
-@@ -43,7 +43,7 @@ extern Pid_t getpid (void);
-  * Some BSDs and Cygwin default to POSIX math instead of IEEE.
-  * This switches them over to IEEE.
-  */
--#if defined(LIBM_LIB_VERSION)
-+#if defined(LIBM_LIB_VERSION) && (defined(__GLIBC__) || defined(__UCLIBC__))
-     _LIB_VERSION_TYPE _LIB_VERSION = _IEEE_;
+--- a/perl.c
++++ b/perl.c
+@@ -286,7 +286,7 @@ perl_construct(pTHXx)
+     PL_localpatches = local_patches;  /* For possible -v */
  #endif
  
+-#if defined(LIBM_LIB_VERSION)
++#if defined(LIBM_LIB_VERSION) && (defined(__GLIBC__) || defined(__UCLIBC__))
+     /*
+      * Some BSDs and Cygwin default to POSIX math instead of IEEE.
+      * This switches them over to IEEE.
index d20345e99ef3e6c5507ef5cd9dac9a47dfc1307f..57de481ecd496e3ecaebd676d293a5ff274c49ab 100644 (file)
@@ -2,7 +2,7 @@ Index: perl-5.26.1/perl.c
 ===================================================================
 --- perl-5.26.1.orig/perl.c
 +++ perl-5.26.1/perl.c
-@@ -1870,16 +1870,6 @@ S_Internals_V(pTHX_ CV *cv)
+@@ -1878,16 +1878,6 @@ S_Internals_V(pTHX_ CV *cv)
      PUSHs(Perl_newSVpvn_flags(aTHX_ non_bincompat_options,
                              sizeof(non_bincompat_options) - 1, SVs_TEMP));
  
index 02e447a5703330c93643d676e2edf745c1356c36..697360aaf9b3bf618d263fc992625aa9bf2e63f7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.SH      2017-10-15 18:57:08.436234652 -0600
 +++ b/Makefile.SH      2017-10-15 19:02:47.587658819 -0600
-@@ -327,7 +327,7 @@ PATH_SEP = $p_
+@@ -328,7 +328,7 @@ PATH_SEP = $p_
  # Macros to invoke a copy of miniperl during the build.  Targets which
  # are built using these macros should depend on \$(MINIPERL_EXE)
  MINIPERL_EXE = miniperl\$(EXE_EXT)
@@ -9,7 +9,7 @@
  
  # Macros to invoke sort the MANIFEST during build
  MANIFEST_SRT = MANIFEST.srt
-@@ -990,7 +990,7 @@ NAMESPACEFLAGS = -force_flat_namespace
+@@ -991,7 +991,7 @@ NAMESPACEFLAGS = -force_flat_namespace
        @$(RMS) miniperl.xok
        $(CC) $(CLDFLAGS) $(NAMESPACEFLAGS) -o $(MINIPERL_EXE) \
            $(miniperl_objs) $(libs)
@@ -18,7 +18,7 @@
        $(MINIPERL) -f write_buildcustomize.pl
  !NO!SUBS!
                ;;
-@@ -1001,16 +1001,16 @@ lib/buildcustomize.pl: $& $(miniperl_obj
+@@ -1002,16 +1002,16 @@ lib/buildcustomize.pl: $& $(miniperl_obj
        @\$(RMS) miniperl.xok
        @\$(RMS) \$(MINIPERL_EXE)
        \$(LNS) \$(HOST_PERL) \$(MINIPERL_EXE)