bigclown-firmware-tool: add new package
authorKarel Kočí <cynerd@email.cz>
Sat, 29 Jun 2019 09:39:40 +0000 (11:39 +0200)
committerKarel Kočí <karel.koci@nic.cz>
Mon, 8 Jul 2019 13:56:50 +0000 (15:56 +0200)
This is tool to flash/manage firmware in Bigclown modules.

Signed-off-by: Karel Kočí <cynerd@email.cz>
utils/bigclown/bigclown-firmware-tool/Makefile [new file with mode: 0644]

diff --git a/utils/bigclown/bigclown-firmware-tool/Makefile b/utils/bigclown/bigclown-firmware-tool/Makefile
new file mode 100644 (file)
index 0000000..2412d33
--- /dev/null
@@ -0,0 +1,46 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-firmware-tool
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/bigclownlabs/bch-firmware-tool/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=2ba459148a5f23773ab14d0f5d5cc381c441d758cb9f23cdbec18b30b07675ab
+PKG_BUILD_DIR:=$(BUILD_DIR)/bch-firmware-tool-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+include ../../../lang/python/python3-package.mk
+
+define Package/$(PKG_NAME)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  SUBMENU:=BigClown
+  TITLE:=BigCLown firmware tool
+  URL:=https://github.com/bigclownlabs/bch-firmware-tool
+  DEPENDS:= \
+    +python3-appdirs \
+    +python3-pyserial \
+    +python3-colorama \
+    +python3-yaml \
+    +python3-schema \
+    +python3-requests \
+    +python3-click \
+    +python3-intelhex
+endef
+
+define Build/Compile
+       sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
+       $(call Py3Build/Compile/Default)
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))