python3: bump to version 3.10.9
authorAlexandru Ardelean <alex@shruggie.ro>
Wed, 25 Jan 2023 12:12:16 +0000 (14:12 +0200)
committerAlexandru Ardelean <alex@shruggie.ro>
Fri, 27 Jan 2023 08:57:15 +0000 (10:57 +0200)
Refresh patches.
Bump setuptools to 65.5.0
Bump pip to 22.3.1
  Removed patch: patches-pip/001-pep517-pyc-fix.patch
  No longer needed as per:
    https://github.com/pypa/pip/commit/fa4b2efbabffb96536c10bfb94477912a0f20e7f

Signed-off-by: Alexandru Ardelean <alex@shruggie.ro>
lang/python/python3-version.mk
lang/python/python3/Makefile
lang/python/python3/patches-pip/.gitkeep [new file with mode: 0644]
lang/python/python3/patches-pip/001-pep517-pyc-fix.patch [deleted file]
lang/python/python3/patches/014-remove-platform-so-suffix.patch
lang/python/python3/patches/016-adjust-config-paths.patch
lang/python/python3/patches/025-choose-python-config-version.patch
lang/python/python3/patches/028-host-python-support-ssl-with-libressl.patch

index d8e72df198e5bdbca10be8fdc1c3720e6b19d6a3..734db18103009ca323c7953ea2287112eec86992 100644 (file)
@@ -8,12 +8,12 @@
 # Note: keep in sync with setuptools & pip
 PYTHON3_VERSION_MAJOR:=3
 PYTHON3_VERSION_MINOR:=10
-PYTHON3_VERSION_MICRO:=7
+PYTHON3_VERSION_MICRO:=9
 
 PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
 
 PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
 PYTHON3_PIP_PKG_RELEASE:=1
 
-PYTHON3_SETUPTOOLS_VERSION:=63.2.0
-PYTHON3_PIP_VERSION:=22.2.2
+PYTHON3_SETUPTOOLS_VERSION:=65.5.0
+PYTHON3_PIP_VERSION:=22.3.1
index 62a7d2a7174a8c423278e6a8db16f457448493ff..6bc001587dfd76a68f63f61e02be8b10074409fe 100644 (file)
@@ -16,7 +16,7 @@ PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
-PKG_HASH:=6eed8415b7516fb2f260906db5d48dd4c06acc0cb24a7d6cc15296a604dcdc48
+PKG_HASH:=5ae03e308260164baba39921fdb4dbf8e6d03d8235a939d4582b33f0b5e46a83
 
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=PSF-2.0
diff --git a/lang/python/python3/patches-pip/.gitkeep b/lang/python/python3/patches-pip/.gitkeep
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/lang/python/python3/patches-pip/001-pep517-pyc-fix.patch b/lang/python/python3/patches-pip/001-pep517-pyc-fix.patch
deleted file mode 100644 (file)
index e600b0a..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/pip/_vendor/pep517/in_process/__init__.py b/pip/_vendor/pep517/in_process/__init__.py
-index c932313..a01143b 100644
---- a/pip/_vendor/pep517/in_process/__init__.py
-+++ b/pip/_vendor/pep517/in_process/__init__.py
-@@ -10,8 +10,13 @@ try:
-     import importlib.resources as resources
-     def _in_proc_script_path():
--        return resources.path(__package__, '_in_process.py')
-+        if resources.is_resource(__package__, '_in_process.py'):
-+            return resources.path(__package__, '_in_process.py')
-+        return resources.path(__package__, '_in_process.pyc')
- except ImportError:
-     @contextmanager
-     def _in_proc_script_path():
--        yield pjoin(dirname(abspath(__file__)), '_in_process.py')
-+        _in_proc_script = pjoin(dirname(abspath(__file__)), '_in_process.py')
-+        if not os.path.isfile(_in_proc_script):
-+            _in_proc_script = pjoin(dirname(abspath(__file__)), '_in_process.pyc')
-+        yield _in_proc_script
index fc3aadbfca2cfeff7c316c3b65e3fe70236dbf6d..82f6c0d8d48e3a2f49c3451d022f6250b9eec7db 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -15616,7 +15616,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
+@@ -15617,7 +15617,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
  $as_echo "$ABIFLAGS" >&6; }
  { $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
  $as_echo_n "checking SOABI... " >&6; }
@@ -11,7 +11,7 @@
  
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4824,7 +4824,7 @@ AC_SUBST(SOABI)
+@@ -4825,7 +4825,7 @@ AC_SUBST(SOABI)
  AC_MSG_CHECKING(ABIFLAGS)
  AC_MSG_RESULT($ABIFLAGS)
  AC_MSG_CHECKING(SOABI)
index 641661f5cb1bd5ae74f3fee87cbba8828dc29966..951e715dabafc7966258b3520737c3ce5a87a89b 100644 (file)
@@ -10,7 +10,7 @@
          '_PYTHON_SYSCONFIGDATA_NAME',
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1593,7 +1593,7 @@ libinstall:      build_all $(srcdir)/Modules/
+@@ -1594,7 +1594,7 @@ libinstall:      build_all $(srcdir)/Modules/
                        esac; \
                done; \
        done
@@ -19,7 +19,7 @@
                $(DESTDIR)$(LIBDEST); \
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
        if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
-@@ -1751,7 +1751,7 @@ sharedinstall: sharedmods
+@@ -1752,7 +1752,7 @@ sharedinstall: sharedmods
                --install-scripts=$(BINDIR) \
                --install-platlib=$(DESTSHARED) \
                --root=$(DESTDIR)/
@@ -39,7 +39,7 @@
      fi
  elif test "$cross_compiling" = maybe; then
      as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
-@@ -15686,7 +15686,7 @@ fi
+@@ -15687,7 +15687,7 @@ fi
  
  
  
@@ -59,7 +59,7 @@
      fi
  elif test "$cross_compiling" = maybe; then
      AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
-@@ -4882,7 +4882,7 @@ fi],
+@@ -4883,7 +4883,7 @@ fi],
  
  dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
  AC_SUBST(PY_ENABLE_SHARED)
index b5a278d8e86315ce649d00cf4a6f7c6f3c106c8a..7b9ee1e6b31b31e9e0d68b9bf8ec8cac4dd8fbf2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -1643,7 +1643,7 @@ python-config: $(srcdir)/Misc/python-con
+@@ -1644,7 +1644,7 @@ python-config: $(srcdir)/Misc/python-con
        @ # On Darwin, always use the python version of the script, the shell
        @ # version doesn't use the compiler customizations that are provided
        @ # in python (_osx_support.py).
index a831735bdc84a748a4d4b1af5616ae9e20e66dbf..45f0e7be53f2091bb7bf14c8a9165a563fe7f69f 100644 (file)
@@ -87,7 +87,7 @@
      return 0;
  }
  
-@@ -4615,8 +4644,10 @@ static PyGetSetDef context_getsetlist[]
+@@ -4619,8 +4648,10 @@ static PyGetSetDef context_getsetlist[]
                          (setter) set_minimum_version, NULL},
      {"maximum_version", (getter) get_maximum_version,
                          (setter) set_maximum_version, NULL},