clamav: Remove build hacks
authorRosen Penev <rosenp@gmail.com>
Wed, 1 May 2019 02:37:52 +0000 (19:37 -0700)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 3 Oct 2019 21:03:21 +0000 (23:03 +0200)
Simplified the Makefile and fixes compilation with uClibc-ng. Also added
IPv6 support.

Took the time to clean up the Makefile with other useful options.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from commit 012e4c1)

net/clamav/Makefile

index 87d14c06a9b184230f91d2a54c41d692ea6a251a..e4d194d0a00932904c2e86689f16e7b65ef12f50 100644 (file)
@@ -11,14 +11,16 @@ PKG_NAME:=clamav
 PKG_VERSION:=0.100.3
 PKG_RELEASE:=1
 
-PKG_LICENSE:=GPL-2.0
-PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr> \
-               Lucian Cristian <lucian.cristian@gmail.com>
-
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.clamav.net/downloads/production/
 PKG_HASH:=5160cdf876c761a7d611f158b7c774ebbbe25856b7c230d9c4e142015e8d3024
 
+PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr> \
+               Lucian Cristian <lucian.cristian@gmail.com>
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING*
+PKG_CPE_ID:=cpe:/a:clamav:clamav
+
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
@@ -56,33 +58,35 @@ endef
 define Package/clamav/conffiles
 endef
 
+CONFIGURE_ARGS += \
+       --sysconfdir=/etc/clamav/ \
+       --disable-bzip2 \
+       --disable-check \
+       --disable-clamdtop \
+       --disable-rpath \
+       --disable-xml \
+       --disable-zlib-vcheck \
+       --with-user=nobody \
+       --with-group=nogroup \
+       --with-libcurl="$(STAGING_DIR)/usr/" \
+       --with-libjson="$(STAGING_DIR)/usr/" \
+       --with-openssl="$(STAGING_DIR)/usr/" \
+       --with-pcre="$(STAGING_DIR)/usr/" \
+       --with-zlib="$(STAGING_DIR)/usr/" \
+       --without-xml \
+       --without-iconv \
+       --without-libncurses-prefix
+
 CONFIGURE_VARS += \
-       INCLUDES="" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
-       $(if $(CONFIG_USE_MUSL),LIBS="-lpthread -lfts",LIBS="-lpthread") \
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --sysconfdir=/etc/clamav/ \
-               --prefix=/usr/ \
-               --exec-prefix=/usr/ \
-               --disable-xml \
-               --disable-bzip2 \
-               --with-user nobody \
-               --with-group nogroup \
-               --with-pcre="$(STAGING_DIR)/usr/" \
-               --with-openssl="$(STAGING_DIR)/usr/" \
-               --with-zlib="$(STAGING_DIR)/usr/" \
-               --disable-zlib-vcheck \
-               --disable-clamdtop \
-       )
-endef
+       ax_cv_uname_syscall=yes \
+       ac_cv_c_mmap_private=yes \
+       have_cv_gai=yes \
+       ac_cv_sys_file_offset_bits=no
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += $(if $(CONFIG_IPV6),have_cv_ipv6=yes)
+
+TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -fno-rtti -flto
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed $(if $(CONFIG_USE_MUSL),-lfts)
 
 define Package/clamav/install
        $(INSTALL_DIR) $(1)/usr/sbin