prosody: do not chown on the host system
authorFelix Fietkau <nbd@openwrt.org>
Fri, 15 Apr 2011 00:43:03 +0000 (00:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 15 Apr 2011 00:43:03 +0000 (00:43 +0000)
SVN-Revision: 26675

net/prosody/Makefile

index 69ac767e8f24e25a4e120e188b15ccc18962fd96..4c1214c23271568bee197a22bfd41cf8e5abbf94 100644 (file)
@@ -95,31 +95,31 @@ shell=/bin/false
 # do not change below
 # check if we are on real system
 if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp -p /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp -p /rom/etc/passwd /etc/passwd
-                fi
-        fi
+       # create copies of passwd and group, if we use squashfs
+       rootfs=`mount |awk '/root/ { print $$5 }'`
+       if [ "$$rootfs" = "squashfs" ]; then
+               if [ -h /etc/group ]; then
+                       rm /etc/group
+                       cp -p /rom/etc/group /etc/group
+               fi
+               if [ -h /etc/passwd ]; then
+                       rm /etc/passwd
+                       cp -p /rom/etc/passwd /etc/passwd
+               fi
+       fi
+
+       echo ""
+       if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
+               echo "adding group $$name to /etc/group"
+               echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
+       fi
+       if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
+               echo "adding user $$name to /etc/passwd"
+               echo "$${name}:x:$${id}:$${id}:$${name}:$${home}:$${shell}" >> $${IPKG_INSTROOT}/etc/passwd
+       fi
+
+       chown -R $${name}:$${name} $${IPKG_INSTROOT}/etc/prosody
 fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:$${home}:$${shell}" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-
-chown -R $${name}:$${name} $${IPKG_INSTROOT}/etc/prosody
 endef
 
 $(eval $(call BuildPackage,prosody))