projects
/
openwrt
/
staging
/
pepe2k.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6b9df46
)
kernel: package crypto_engine driver
author
Thomas Richard
<thomas.richard@bootlin.com>
Tue, 5 Nov 2024 09:38:49 +0000
(10:38 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 23 Nov 2024 14:53:21 +0000
(15:53 +0100)
It is needed for the stm32/stm32mp1 subtarget.
Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link:
https://github.com/openwrt/openwrt/pull/16716
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index ce221635470302d657dfbba95d4d962d9f1270e0..2257a36c802cdaf576c535758e7b2d0ba877d589 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-249,6
+249,15
@@
endef
$(eval $(call KernelPackage,crypto-echainiv))
+define KernelPackage/crypto-engine
+ TITLE:=Crypto engine
+ KCONFIG:=CONFIG_CRYPTO_ENGINE
+ FILES:=$(LINUX_DIR)/crypto/crypto_engine.ko
+ AUTOLOAD:=$(call AutoLoad,09,crypto_engine)
+ $(call AddDepends/crypto, +kmod-crypto-rsa +kmod-crypto-kpp)
+endef
+
+$(eval $(call KernelPackage,crypto-engine))
define KernelPackage/crypto-essiv
TITLE:=ESSIV support for block encryption