v2raya: remove go version hack
authorTianling Shen <cnsztl@immortalwrt.org>
Sat, 30 Sep 2023 11:00:55 +0000 (19:00 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Sat, 30 Sep 2023 11:05:11 +0000 (19:05 +0800)
This hack was added for Go 1.20 as it did not take minor version.
Now we have Go 1.21, this hack can go away.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
net/v2raya/Makefile
net/v2raya/patches/010-go-version.patch [deleted file]

index eec759a7b328fb6307214b505f11abad3ad318b0..21852988f592760f90ee7a0dc84c27971172ea8a 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=v2rayA
 PKG_VERSION:=2.2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
diff --git a/net/v2raya/patches/010-go-version.patch b/net/v2raya/patches/010-go-version.patch
deleted file mode 100644 (file)
index f9b2ba9..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/go.mod
-+++ b/go.mod
-@@ -1,6 +1,6 @@
- module github.com/v2rayA/v2rayA
--go 1.21.0
-+go 1.21
- require (
-       github.com/daeuniverse/outbound v0.0.0-20230819151251-3ce60883d337