python3-libsemanage: Update to 3.5, rename source/target package
authorJeffery To <jeffery.to@gmail.com>
Thu, 8 Jun 2023 08:45:07 +0000 (16:45 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 26 Jun 2023 04:25:49 +0000 (12:25 +0800)
* Rename:

  * Source package from python3-libsemanage to python-semanage
  * Target package from python3-libsemanage to python3-semanage

* Update dependents with new target package name

* Update package title, license files, and dependencies

* Remove Build/InstallDev (files not used by any other package)

* Use Py3Package to build Python bytecode and source packages

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 23ff8177f030610f40300519cd888dbfd47f3e3a)

lang/python/python-semanage/Makefile [new file with mode: 0644]
lang/python/python3-libsemanage/Makefile [deleted file]
utils/selinux-python/Makefile

diff --git a/lang/python/python-semanage/Makefile b/lang/python/python-semanage/Makefile
new file mode 100644 (file)
index 0000000..33e148c
--- /dev/null
@@ -0,0 +1,64 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-semanage
+PKG_VERSION:=3.5
+PKG_RELEASE:=1
+
+SRC_NAME:=libsemanage
+PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
+PKG_HASH:=f53534e50247538280ed0d76c6ce81d8fb3939bd64cadb89da10dba42e40dd9c
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(SRC_NAME)-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=LICENSE
+PKG_CPE_ID:=cpe:/a:selinuxproject:libsemanage
+
+PKG_BUILD_DEPENDS:=swig/host
+PKG_BUILD_PARALLEL:=1
+PYTHON3_PKG_BUILD:=0
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-semanage
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=SELinux policy management library bindings
+  DEPENDS:=+python3-light +libsemanage
+  URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/python3-semanage/description
+       libsemanage is the policy management library. It uses
+       libsepol for binary policy manipulation and libselinux for
+       interacting with the SELinux system. It also exec's helper
+       programs for loading policy and for checking whether the
+       file_contexts configuration is valid (load_policy and
+       setfiles from policycoreutils) presently, although this may
+       change at least for the bootstrapping case (for rpm).
+
+       This package provides the Python bindings for libsemanage.
+endef
+
+MAKE_VARS += \
+       $(PYTHON3_VARS)
+
+define Build/Compile
+       $(call Build/Compile/Default,pywrap)
+endef
+
+define Build/Install
+       $(call Build/Install/Default,install-pywrap)
+endef
+
+$(eval $(call Py3Package,python3-semanage))
+$(eval $(call BuildPackage,python3-semanage))
+$(eval $(call BuildPackage,python3-semanage-src))
diff --git a/lang/python/python3-libsemanage/Makefile b/lang/python/python3-libsemanage/Makefile
deleted file mode 100644 (file)
index c1a8257..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-SRC_NAME:=libsemanage
-PKG_NAME:=python3-$(SRC_NAME)
-PKG_VERSION:=3.2
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/python-libsemanage/$(SRC_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
-PKG_HASH:=d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511
-PKG_BUILD_DEPENDS:=swig/host
-
-PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-PKG_LICENSE:=LGPL-2.1-or-later
-PKG_LICENSE_FILES:=COPYING
-PKG_CPE_ID:=cpe:/a:selinuxproject:libsemanage
-PYTHON3_PKG_BUILD:=0
-PKG_INSTALL:=1
-MAKE_PATH:=src
-
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-libsemanage
-  TITLE:=Python bindings for the SELinux policy management library
-  SUBMENU:=Python
-  SECTION:=lang
-  CATEGORY:=Languages
-  DEPENDS:=+python3 +libsemanage
-  URL:=http://selinuxproject.org/page/Main_Page
-endef
-
-define Package/python3-libsemanage/description
-       libsemanage is the policy management library. It uses
-       libsepol for binary policy manipulation and libselinux for
-       interacting with the SELinux system. It also exec's helper
-       programs for loading policy and for checking whether the
-       file_contexts configuration is valid (load_policy and
-       setfiles from policycoreutils) presently, although this may
-       change at least for the bootstrapping case (for rpm).
-
-       This package provides the Python bindings for libsemanage.
-endef #'
-
-MAKE_FLAGS += \
-       PYTHON=$(PYTHON3) \
-       PYINC="-I $(PYTHON3_INC_DIR)" \
-       PYLIBS="-lpython$(PYTHON3_VERSION)" \
-       $(PYTHON3_VARS)
-
-define Build/Compile
-       $(call Build/Compile/Default,swigify pywrap)
-endef
-
-define Build/Install
-       $(call Build/Install/Default,install-pywrap)
-endef
-
-define Build/Configure
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)$(PYTHON3_PKG_DIR)
-       $(CP) $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/* $(1)$(PYTHON3_PKG_DIR)
-endef
-
-define Package/python3-libsemanage/install
-       $(INSTALL_DIR) $(1)$(PYTHON3_PKG_DIR)
-       $(CP) $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/* $(1)$(PYTHON3_PKG_DIR)
-endef
-
-$(eval $(call BuildPackage,python3-libsemanage))
index af025c7b0e002846f033bd1cde4661f80a3a69a5..ed51bc7f30db251fd1820ced72f73c6179e285b5 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=selinux-python
 PKG_VERSION:=3.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
@@ -93,7 +93,7 @@ endef
 define Package/selinux-semanage
 $(call Package/selinux-python/Default)
   TITLE:=selinux-semanage
-  DEPENDS+=+python3-sepolicy +python3-libsemanage +setools
+  DEPENDS+=+python3-sepolicy +python3-semanage +setools
 endef
 
 define Package/selinux-semanage/description