samba4: update to 4.14.5
authorAndy Walsh <andy.walsh44+github@gmail.com>
Sun, 27 Jun 2021 13:15:26 +0000 (15:15 +0200)
committerAndy Walsh <andy.walsh44+github@gmail.com>
Sun, 27 Jun 2021 13:32:34 +0000 (15:32 +0200)
* update to 4.14.5
* refresh patches

Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
net/samba4/Makefile
net/samba4/patches/001-samba-4.4.0-pam.patch
net/samba4/patches/006-netdb-defines.patch
net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch
net/samba4/patches/008-samba-4.11-add_missing___compar_fn_t.patch
net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch
net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch

index 06c97bc8280e49cbeab356abc9b7c092c6b088b1..f3108fc583b858075818c6d62f3207e1b90f43d4 100644 (file)
@@ -2,7 +2,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=4.13.9
+PKG_VERSION:=4.14.5
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
                http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
                http://samba.mirror.bit.nl/samba/ftp/stable/ \
                https://download.samba.org/pub/samba/stable/
-PKG_HASH:=b97a773ed3b4dae6d5ebd3e09337c897ae898b65f38abad550f852b594d4e07f
+PKG_HASH:=bb6ef5d2f16b85288d823578abc453d9a80514c42e5a2ea2c4e3c60dc42335c3
 
 PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
 PKG_LICENSE:=GPL-3.0-only
index f52e2efb2548fb1f882911c1399ef4bc48ea19ab..72de06619880f0d0c80298e65c0ca8a0c80833b9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/source3/wscript
 +++ b/source3/wscript
-@@ -907,7 +907,7 @@ msg.msg_accrightslen = sizeof(fd);
+@@ -885,7 +885,7 @@ msg.msg_accrightslen = sizeof(fd);
          if conf.env.with_iconv:
              conf.DEFINE('HAVE_ICONV', 1)
  
@@ -9,7 +9,7 @@
          use_pam=True
          conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h')
          if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'):
-@@ -984,6 +984,17 @@ int i; i = PAM_RADIO_TYPE;
+@@ -962,6 +962,17 @@ int i; i = PAM_RADIO_TYPE;
                         "or headers not found. Use --without-pam to disable "
                         "PAM support.");
  
index 7cb073c1501b9e6888bfd89a660994e4bbe66d13..a11f8d15c5877e435f9d4beebcb65cdee468b90c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/nsswitch/wins.c
 +++ b/nsswitch/wins.c
-@@ -39,6 +39,14 @@ static pthread_mutex_t wins_nss_mutex =
+@@ -40,6 +40,14 @@ static pthread_mutex_t wins_nss_mutex =
  #define INADDRSZ 4
  #endif
  
index 192cf564d45e10e00ae1185be6f8d95889a690a0..29928976b4a594fe47a4e4de125ffdee15bb57aa 100644 (file)
@@ -22,5 +22,5 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
 +#include <sys/stat.h>
 +#include <sys/types.h>
  
- struct tevent_context;
- struct tevent_ops;
+ /* for old gcc releases that don't have the feature test macro __has_attribute */
+ #ifndef __has_attribute
index 96b65e6c582128d787183f8c8b96413d8053f78f..401835df8bfb97b8d9cb75f1a0ad9fb1cbf57c2f 100644 (file)
@@ -1,8 +1,8 @@
 --- a/source4/dsdb/samdb/ldb_modules/count_attrs.c
 +++ b/source4/dsdb/samdb/ldb_modules/count_attrs.c
-@@ -38,6 +38,11 @@
- #define NULL_REQ_PSEUDO_N -2LL;
- #define STAR_REQ_PSEUDO_N -4LL;
+@@ -40,6 +40,11 @@
+ #undef strcasecmp
  
 +#ifndef __COMPAR_FN_T
 +#define __COMPAR_FN_T
index 507b74c9cb89eceb62fea68f242be8da87033344..284c09d85a677edd885a1a3cd1cb0d29d128bb9b 100644 (file)
@@ -1,6 +1,8 @@
 --- a/wscript_configure_embedded_heimdal
 +++ b/wscript_configure_embedded_heimdal
-@@ -1 +1,12 @@
+@@ -2,3 +2,14 @@ if not conf.env['FLEX']:
+     conf.fatal("Embedded Heimdal build requires flex but it was not found.  Install flex or use --with-system-mitkrb5 or --with-system-heimdalkrb5")
  conf.RECURSE('source4/heimdal_build')
 +
 +def check_system_heimdal_binary(name):
index 8bb80897d4b865dee39228f60a973ef84ddef3a1..a1b97e0f3fd89bc9816ed824390f2602b886e7e4 100644 (file)
@@ -29,7 +29,7 @@
  
      conf.CHECK_CODE('''
                  struct ucred cred;
-@@ -809,9 +800,6 @@ def configure(conf):
+@@ -807,9 +798,6 @@ def configure(conf):
  
      # look for a method of finding the list of network interfaces
      for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
@@ -39,7 +39,7 @@
          if conf.CHECK_CODE('''
                             #define %s 1
                             #define NO_CONFIG_H 1
-@@ -824,7 +812,7 @@ def configure(conf):
+@@ -822,7 +810,7 @@ def configure(conf):
                             #include "tests/getifaddrs.c"
                             ''' % method,
                             method,
@@ -48,7 +48,7 @@
                             addmain=False,
                             execute=True):
              break
-@@ -872,7 +860,6 @@ def build(bld):
+@@ -870,7 +858,6 @@ def build(bld):
                  break
  
      extra_libs = ''