unbound: fix local dns synthesis corner cases
authorEric Luehrsen <ericluehrsen@gmail.com>
Tue, 30 Apr 2019 02:51:55 +0000 (22:51 -0400)
committerEric Luehrsen <ericluehrsen@gmail.com>
Tue, 30 Apr 2019 02:51:55 +0000 (22:51 -0400)
Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
net/unbound/Makefile
net/unbound/files/odhcpd.awk
net/unbound/files/unbound.sh

index 0c35e45d9bc6add9ac6b45e33784ddf67992243a..527550535949a5553e6ec3f62829e6732f08a844 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unbound
 PKG_VERSION:=1.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
index 3c5378870025dd0071c9d987e86a24ef600e4134..8c303029e4d63acb34e43123fa5b1314a5ec29ac 100644 (file)
@@ -85,6 +85,7 @@
 
       while ( ( cmd | getline adr ) > 0 ) {
         if (( substr( adr, 1, 5 ) <= "fdff:" ) \
+        && ( index( adr, "::/" ) != 0 ) \
         && ( index( adr, "anycast" ) == 0 ) \
         && ( index( adr, "via" ) == 0 )) {
           # GA or ULA routed addresses only (not LL or MC)
index 529b689f947ec3013f715eb70e3dd7c704a860a2..e03d93c6472330f7e7a50d0e3edd30037c8daa3e 100644 (file)
@@ -113,7 +113,7 @@ create_interface_dns() {
   # Create local-data: references for this hosts interfaces (router).
   config_get logint "$cfg" interface
   config_get_bool ignore "$cfg" ignore 0
-  network_get_device ifname "$cfg"
+  network_get_device ifname "$logint"
 
   ifdashname="${ifname//./-}"
   ipcommand="ip -o address show $ifname"