libcoap: make sure `libcoap-3-notls.so` is installed
authorLeo Soares <leo@hyper.ag>
Mon, 16 May 2022 23:02:26 +0000 (00:02 +0100)
committerRosen Penev <rosenp@gmail.com>
Fri, 20 May 2022 19:14:40 +0000 (12:14 -0700)
This commit fixes an issue where the `libcoap-3-notls.so` is not installed,
in some cases leaving the target's root with no library and just a broken link
from `libcoap-3.so` to `libcoap-3-notls.so`.

Signed-off-by: Leo Soares <leo@hyper.ag>
libs/libcoap/Makefile

index 56d8840346caba59fb8d8c11516db463b4797117..eef8820fdb3f10a786a0ee56323e3a7ee9d6eae6 100644 (file)
@@ -79,7 +79,7 @@ endef
 
 define Package/libcoap/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcoap-$(ABI_VERSION).so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcoap-$(ABI_VERSION)*.so* $(1)/usr/lib/
 endef
 
 define Package/coap-client/install