gammu: fix mysql depend
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 29 Apr 2018 16:48:51 +0000 (18:48 +0200)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 29 Apr 2018 16:57:12 +0000 (18:57 +0200)
mysql was replaced by mariadb. The lazy dependency
"+PACKAGE_libmysqlclient:libmysqlclient" does not work anymore as
"PACKAGE_libmysqlclient" no longer exists. This results in:

Package gammu is missing dependencies for the following libraries:
libmysqlclient.so.18

This commit addresses that.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/gammu/Makefile

index 20de09ef48c78de3b66b15d10ffa9e342cb9bde4..825ad1859720aa5f37a2aca8d1d2b0af8784e7f3 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gammu
 PKG_VERSION:=1.38.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://dl.cihar.com/gammu/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -31,7 +31,7 @@ define Package/gammu
        URL:=http://dl.cihar.com/gammu/releases/
        DEPENDS:=+libpthread +libcurl +glib2 $(ICONV_DEPENDS) $(INTL_DEPENDS)
        DEPENDS+=+PACKAGE_python:python +PACKAGE_bluez-libs:bluez-libs
-       DEPENDS+=+PACKAGE_libmysqlclient:libmysqlclient +PACKAGE_unixodbc:unixodbc +PACKAGE_libpq:libpq
+       DEPENDS+=+PACKAGE_libmariadbclient:libmariadbclient +PACKAGE_unixodbc:unixodbc +PACKAGE_libpq:libpq
        DEPENDS+=+PACKAGE_libusb-1.0:libusb-1.0
 endef