python-pytz: remove host-build
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 3 Jun 2019 12:20:20 +0000 (15:20 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 18 Jun 2019 12:08:12 +0000 (15:08 +0300)
seafile-seahub was the only user of this.
Remove this from the build.
Having it here is a bit messy.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python-pytz/Makefile

index 1fec0d5492984729018ce8999bfc4c11dc70380b..b3acbd104c1a297779983e1ebfd85406483728d7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pytz
 PKG_VERSION:=2019.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=pytz-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/pytz
@@ -21,15 +21,11 @@ PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE.txt
 
-HOST_BUILD_DEPENDS:=python/host
-
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
 include ../python3-package.mk
 
 PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-HOST_UNPACK:=$(HOST_TAR) -C $(HOST_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
 define Package/python-pytz/Default
   SUBMENU:=Python
@@ -62,14 +58,6 @@ $(call Package/python-pytz/description)
 (Variant for Python3)
 endef
 
-define Host/Compile
-       $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
-endef
-
-Host/Install:=
-
-$(eval $(call HostBuild))
-
 $(eval $(call PyPackage,python-pytz))
 $(eval $(call BuildPackage,python-pytz))
 $(eval $(call BuildPackage,python-pytz-src))