ncdu: Update to 1.14.1
authorRosen Penev <rosenp@gmail.com>
Fri, 18 Oct 2019 22:20:31 +0000 (15:20 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 18 Oct 2019 22:20:31 +0000 (15:20 -0700)
Several Makefile cleanups for consistency.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/ncdu/Makefile

index 40ea80f226995c14cd34c6399385c6d66b2025d2..8ad400449503ee43d915737fe92d6c3805443394 100644 (file)
@@ -8,19 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncdu
-PKG_VERSION:=1.14
-PKG_RELEASE=1
+PKG_VERSION:=1.14.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://dev.yorhel.nl/download
-PKG_HASH:=c694783aab21e27e64baad314b7c1ff34541bfa219fe9645ef6780f1c5558c44
-
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
+PKG_HASH:=be31e0e8c13a0189f2a186936f7e298c6390ebdc573bb4a1330bc1fcbf56e13e
 
+PKG_MAINTAINER:=Charles Lehner <celehner1@gmail.com>
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
 
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ncdu
@@ -29,7 +30,6 @@ define Package/ncdu
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=ncurses disk usage viewer
-  MAINTAINER:=Charles Lehner <celehner1@gmail.com>
   URL:=https://dev.yorhel.nl/ncdu
 endef
 
@@ -39,8 +39,6 @@ define Package/ncdu/description
   directories and show percentages of disk usage with ncurses library.
 endef
 
-CONFIGURE_ARGS += --with-ncurses
-
 define Package/ncdu/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ncdu $(1)/usr/bin/