atlas-sw-probe: fix copypaste error and clean tmp dir on exit
authorAnsuel Smith <ansuelsmth@gmail.com>
Mon, 2 Aug 2021 13:08:22 +0000 (15:08 +0200)
committerAnsuel Smith <ansuelsmth@gmail.com>
Mon, 2 Aug 2021 13:11:01 +0000 (15:11 +0200)
- Fix copypaste error for PUB_KEY link creation
- Clean tmp dir on exit to clear any remaining data

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
net/atlas-sw-probe/Makefile
net/atlas-sw-probe/files/atlas.init

index 445d7ff586e42f8abc704082501e89fd2182d7e8..d300317d8cf8624339ad56ef6e8baa13c8ff23e5 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=atlas-sw-probe
 PKG_VERSION:=5020
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/RIPE-NCC/ripe-atlas-software-probe.git
index a833a9510cbe4a2380ef68986d9ac73433233f46..a0fe8192d71e9fe5eeed17eb202973b3ac34e14d 100644 (file)
@@ -100,7 +100,7 @@ create_key() {
 
        #Link priv/pub key
        [ -f $PRIV_KEY_FILE ] || ln -s $probe_key $PRIV_KEY_FILE
-       [ -f $PRIV_KEY_FILE ] || ln -s $probe_pub_key $PUB_KEY_FILE
+       [ -f $PUB_KEY_FILE ] || ln -s $probe_pub_key $PUB_KEY_FILE
 
        #Fix permission
        chown atlas $probe_key $probe_pub_key
@@ -177,6 +177,9 @@ stop_service() {
                        kill "$tunnel_pid"
                fi
        fi
+
+       # Clean run dir
+       rm -r $TMP_BASE_DIR
 }
 
 safe_mkdir() {