netbird: revert fix to build with musl >1.2.4
authorWesley Gimenes <wehagy@proton.me>
Sun, 22 Dec 2024 22:21:31 +0000 (19:21 -0300)
committerTianling Shen <cnsztl@gmail.com>
Mon, 30 Dec 2024 03:33:00 +0000 (11:33 +0800)
Partially revert: 7b3d033ab651dd11e0db5fb099d106c9e09a2dc6
 - Revert: Also fixes issue of not being able to build with musl >1.2.4,
   The issue has been resolved as of March 2024. For more details, see:
   https://github.com/mattn/go-sqlite3/issues/1164#issuecomment-1975022901

Signed-off-by: Wesley Gimenes <wehagy@proton.me>
net/netbird/Makefile

index 88149d1704fee56d73c5f68fef61caa505e662de..4190c0dda63b7d9ee217780d6a504433efe6d610 100644 (file)
@@ -44,12 +44,6 @@ define Package/netbird/conffiles
 /etc/netbird/config.json
 endef
 
-# Workaround for musl 1.2.4 compability in mattn/go-sqlite3
-# https://github.com/mattn/go-sqlite3/issues/1164
-ifneq ($(CONFIG_USE_MUSL),)
-       TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
-endif
-
 define Package/netbird/install
        $(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
        $(INSTALL_DIR) $(1)/usr/bin $(1)/etc/init.d