zerotier: keep configuration file on update
authorMoritz Warning <moritzwarning@web.de>
Thu, 4 Jul 2019 13:52:09 +0000 (15:52 +0200)
committerMoritz Warning <moritzwarning@web.de>
Thu, 4 Jul 2019 19:36:00 +0000 (21:36 +0200)
Signed-off-by: Moritz Warning <moritzwarning@web.de>
net/zerotier/Makefile

index 50a270a87ec4b73b05cd81ee3f029910b987fe25..7cf5a44cb705a0f1ee75b7e1952a1b18a63c2336 100644 (file)
@@ -7,15 +7,16 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zerotier
 PKG_VERSION:=1.2.12
-PKG_RELEASE:=3
-
-PKG_LICENSE:=GPL-3.0
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_HASH:=212799bfaeb5e7dff20f2cd83f15742c8e13b8e9535606cfb85abcfb5fb6fed4
 PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
 
+PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=LICENSE.txt
 
 PKG_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/package.mk
@@ -27,7 +28,6 @@ define Package/zerotier
   TITLE:=Create flat virtual Ethernet networks of almost unlimited size
   URL:=https://www.zerotier.com
   SUBMENU:=VPN
-  MAINTAINER:=Moritz Warning <moritzwarning@web.de>
 endef
 
 define Package/zerotier/description
@@ -56,6 +56,10 @@ endef
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
+define Package/zerotier/conffiles
+/etc/config/zerotier
+endef
+
 define Package/zerotier/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/zerotier-one $(1)/usr/bin/