shairport-sync: Install /etc/config as 600
authorRosen Penev <rosenp@gmail.com>
Fri, 17 Aug 2018 04:02:38 +0000 (21:02 -0700)
committerGitHub <noreply@github.com>
Fri, 17 Aug 2018 04:02:38 +0000 (21:02 -0700)
/etc/config should not be readable by non-root.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
sound/shairport-sync/Makefile

index c5c15823b58e94f2088b124fc42221cea9dadaab..1d977443ad79c992c41497b74f2385748251b5f4 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shairport-sync
 PKG_VERSION:=3.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/mikebrady/shairport-sync.git
@@ -113,7 +113,7 @@ define Package/shairport-sync/default/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/shairport-sync.init $(1)/etc/init.d/shairport-sync
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/shairport-sync.config $(1)/etc/config/shairport-sync
+       $(INSTALL_CONF) ./files/shairport-sync.config $(1)/etc/config/shairport-sync
 endef
 
 Package/shairport-sync-openssl/install = $(Package/shairport-sync/default/install)