ath79: DO NOT MERGE: add a custom WR741N v1/v2 8Mb variant
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 27 Aug 2022 14:57:13 +0000 (16:57 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 28 Aug 2022 21:23:10 +0000 (23:23 +0200)
Device is a WR741N v2.4 (AR7240) with the flash replaced with
an 8Mb chip. ART partition is moved to the end (0x7f0000). Also,
the commit adds the 741-related code back to the generic board.d
files.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic-tp-link.mk

diff --git a/target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts b/target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts
new file mode 100644 (file)
index 0000000..8532d29
--- /dev/null
@@ -0,0 +1,42 @@
+target/linux/ath79/dts/ar7240_tplink_tl-wr741-v1-8m.dts
+
+#include "ar7240_tplink_tl-wr.dtsi"
+
+/ {
+       model = "TP-Link TL-WR741N/ND v1/v2 8Mb custom board";
+       compatible = "tplink,tl-wr741-v1-8m", "qca,ar7240";
+};
+
+/delete-node/ &art;
+
+&spi {
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               reg = <0x0 0x20000>;
+                               label = "u-boot";
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               reg = <0x20000 0x7d0000>;
+                               label = "firmware";
+                               compatible = "tplink,firmware";
+                       };
+
+                       art: partition@7f0000 {
+                               reg = <0x7f0000 0x10000>;
+                               label = "art";
+                               read-only;
+                       };
+               };
+       };
+};
index 188262018ca4962c005e18cca3e29af9557f6a35..3a90d54eb48f3a41efa7b50701af5705622ea41a 100644 (file)
@@ -419,6 +419,13 @@ tplink,tl-mr6400-v1)
 tplink,tl-wpa8630-v1)
        ucidef_set_led_switch "lan" "LAN" "green:lan" "switch0" "0x3c"
        ;;
+tplink,tl-wr741-v1-8m)
+       ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth0"
+       ucidef_set_led_switch "lan1" "LAN1" "green:lan1" "switch0" "0x02"
+       ucidef_set_led_switch "lan2" "LAN2" "green:lan2" "switch0" "0x04"
+       ucidef_set_led_switch "lan3" "LAN3" "green:lan3" "switch0" "0x08"
+       ucidef_set_led_switch "lan4" "LAN4" "green:lan4" "switch0" "0x10"
+       ;;
 tplink,tl-wr841hp-v2|\
 tplink,tl-wr842n-v2)
        ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth1"
index c576dacee50eda6bebb2d2099f7f40c9dff03746..11fd7def3fbad146e6ab2fedc91968dc86afea21 100644 (file)
@@ -455,6 +455,11 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan:3" "3:lan:2" "4:lan:1" "5:lan:4"
                ;;
+       tplink,tl-wr741-v1-8m)
+               ucidef_set_interface_wan "eth0"
+               ucidef_add_switch "switch0" \
+                       "0@eth1" "1:lan" "2:lan" "3:lan" "4:lan"
+               ;;
        tplink,tl-wr841hp-v2|\
        tplink,tl-wr842n-v2|\
        tplink,tl-wr941hp-v1)
index 95439b9b276938d0532fb5527250a5947a66d86e..f248e3586cfb7d5eea6170ee8f1f4acd366484c4 100644 (file)
@@ -117,6 +117,7 @@ case "$FIRMWARE" in
        netgear,wnr2200-16m|\
        pcs,cap324|\
        tplink,tl-wr2543-v1|\
+       tplink,tl-wr741-v1-8m|\
        tplink,tl-wr842n-v1)
                caldata_extract "art" 0x1000 0x1000
                ;;
index ffe1d6e290a1dcff21a8f9d695e96b44225b6a96..3a1b2e4d26c2a79375cca260177bc16271341f6d 100644 (file)
@@ -782,6 +782,17 @@ define Device/tplink_tl-wr710n-v2.1
 endef
 TARGET_DEVICES += tplink_tl-wr710n-v2.1
 
+define Device/tplink_tl-wr741-v1-8m
+  $(Device/tplink-8m)
+  SOC := ar7240
+  DEVICE_MODEL := TL-WR741N/ND
+  DEVICE_VARIANT := v1/v2 8M
+  TPLINK_HWID := 0x07410001
+  DEVICE_PACKAGES := kmod-owl-loader
+  SUPPORTED_DEVICES += tl-wr741nd
+endef
+TARGET_DEVICES += tplink_tl-wr741-v1-8m
+
 define Device/tplink_tl-wr810n-v1
   $(Device/tplink-8mlzma)
   SOC := qca9531