rtl-sdr: Update to 0.6.0
authorRosen Penev <rosenp@gmail.com>
Mon, 19 Nov 2018 22:12:57 +0000 (14:12 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 19 Nov 2018 22:14:35 +0000 (14:14 -0800)
Patch was upstreamed.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/rtl-sdr/Makefile
utils/rtl-sdr/patches/101-fix-inlines.patch [deleted file]

index 02574b42273c420cb34f2885bae7f2f8d3663d0b..5922d77a0bba84bf2e8fb59cd3d17b05ca52b9a0 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtl-sdr
-PKG_VERSION:=0.5.4
+PKG_VERSION:=0.6.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.osmocom.org/rtl-sdr/snapshot
-PKG_HASH:=f38da8a230de5fc997f83a19cff7f8c1a66b62a9cf70ddc997d44696b97ea1df
+PKG_HASH:=ee10a76fe0c6601102367d4cdf5c26271e9442d0491aa8df27e5a9bf639cff7c
 
 PKG_BUILD_PARALLEL:=1
 CMAKE_INSTALL:=1
diff --git a/utils/rtl-sdr/patches/101-fix-inlines.patch b/utils/rtl-sdr/patches/101-fix-inlines.patch
deleted file mode 100644 (file)
index c30cc8d..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-From 6c01778cf7ff81d9a571291fee615b65961ca1d5 Mon Sep 17 00:00:00 2001
-From: David Woodhouse <dwmw2@infradead.org>
-Date: Thu, 28 Jun 2018 16:21:11 +0100
-Subject: [PATCH] Fix inline functions to use 'static inline'
-
-With just 'inline', if the compiler decides not to inline them, it isn't
-required to emit them at all. For some targets with -Os that is causing
-build failures.
-
-Perhaps we might consider using '__attribute__((always_inline))' for
-GCC builds, but 'static inline' is a good start.
----
- src/rtl_adsb.c  | 8 ++++----
- src/rtl_power.c | 2 +-
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/rtl_adsb.c b/src/rtl_adsb.c
-index 9087de4..7aea8dd 100644
---- a/src/rtl_adsb.c
-+++ b/src/rtl_adsb.c
-@@ -183,7 +183,7 @@ int magnitute(uint8_t *buf, int len)
-       return len/2;
- }
--inline uint16_t single_manchester(uint16_t a, uint16_t b, uint16_t c, uint16_t d)
-+static inline uint16_t single_manchester(uint16_t a, uint16_t b, uint16_t c, uint16_t d)
- /* takes 4 consecutive real samples, return 0 or 1, BADSAMPLE on error */
- {
-       int bit, bit_p;
-@@ -224,17 +224,17 @@ inline uint16_t single_manchester(uint16_t a, uint16_t b, uint16_t c, uint16_t d
-       return BADSAMPLE;
- }
--inline uint16_t min16(uint16_t a, uint16_t b)
-+static inline uint16_t min16(uint16_t a, uint16_t b)
- {
-       return a<b ? a : b;
- }
--inline uint16_t max16(uint16_t a, uint16_t b)
-+static inline uint16_t max16(uint16_t a, uint16_t b)
- {
-       return a>b ? a : b;
- }
--inline int preamble(uint16_t *buf, int i)
-+static inline int preamble(uint16_t *buf, int i)
- /* returns 0/1 for preamble at index i */
- {
-       int i2;
-diff --git a/src/rtl_power.c b/src/rtl_power.c
-index 00f4d9f..625d818 100644
---- a/src/rtl_power.c
-+++ b/src/rtl_power.c
-@@ -250,7 +250,7 @@ void sine_table(int size)
-       }
- }
--inline int16_t FIX_MPY(int16_t a, int16_t b)
-+static inline int16_t FIX_MPY(int16_t a, int16_t b)
- /* fixed point multiply and scale */
- {
-       int c = ((int)a * (int)b) >> 14;
--- 
-2.7.4
-