gost_engine: fix config installation directory
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 27 May 2024 16:51:53 +0000 (13:51 -0300)
committerRosen Penev <rosenp@gmail.com>
Tue, 28 May 2024 03:17:56 +0000 (20:17 -0700)
The engine configuration directory was moved to /etc/ssl/modules.cnf.d/,
but the gost_engine package was using /etc/ssl/engines.cnf.d/ by
mistake.

Fixes: 3b2fcd6b2 ("gost_engine: adapt to new engine build config")
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/gost_engine/Makefile

index 308b7e45b497bcdb3cfd6933108db688f1df2951..e6a806672239850fd1a4d730f9472e76dfaeb031 100644 (file)
@@ -3,7 +3,7 @@ include $(INCLUDE_DIR)/openssl-module.mk
 
 PKG_NAME:=gost_engine
 PKG_VERSION:=3.0.3
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=v$(PKG_VERSION)
@@ -60,12 +60,12 @@ endef
 CMAKE_OPTIONS += -DOPENSSL_ENGINES_DIR=/usr/lib/$(ENGINES_DIR)
 
 define Package/libopenssl-gost_engine/install
-       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/lib/$(ENGINES_DIR) $(1)/etc/ssl/engines.cnf.d
+       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/lib/$(ENGINES_DIR) $(1)/etc/ssl/modules.cnf.d
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libgost.so \
                        $(1)/usr/lib/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/$(ENGINES_DIR)/gost.so \
                        $(1)/usr/lib/$(ENGINES_DIR)/
-       $(INSTALL_DATA) ./files/gost.cnf $(1)/etc/ssl/engines.cnf.d/
+       $(INSTALL_DATA) ./files/gost.cnf $(1)/etc/ssl/modules.cnf.d/
 endef
 
 define Package/gost_engine-util/install