xr_usb_serial_common: fix 32-bit compilation
authorRosen Penev <rosenp@gmail.com>
Tue, 9 Jul 2024 21:27:55 +0000 (14:27 -0700)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 12 Jul 2024 20:14:24 +0000 (21:14 +0100)
Format needs to be %zd, not %ld for size_t.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/xr_usb_serial_common/Makefile
libs/xr_usb_serial_common/patches/0001-fix-kernel-6.6-builds.patch

index c1ea1be7aa46872410a9bf31a00a85ba3dc9001d..85348c21e3185e78001394795407bea88fb07b6f 100644 (file)
@@ -4,7 +4,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=usb-serial-xr_usb_serial_common
 PKG_SOURCE_DATE:=2023-03-21
 PKG_SOURCE_VERSION:=90ad530166f096347a5a57b6f9eb21c422a40fd9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/kasbert/epsolar-tracer
index 3389aeb92ff19bd9f93a2ad897ef19394c190586..beb3188a2b4f1319224eb3741c36c3bf2f3e151f 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
                return 0;
  
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 2, 0)
-+      dev_vdbg(&xr_usb_serial->data->dev, "%s - count %ld\n", __func__, count);
++      dev_vdbg(&xr_usb_serial->data->dev, "%s - count %zd\n", __func__, count);
 +#else
        dev_vdbg(&xr_usb_serial->data->dev, "%s - count %d\n", __func__, count);
 +#endif
@@ -43,7 +43,7 @@ Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
  
        count = (count > xr_usb_serial->writesize) ? xr_usb_serial->writesize : count;
 +#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 2, 0)
-+      dev_vdbg(&xr_usb_serial->data->dev, "%s - write %ld\n", __func__, count);
++      dev_vdbg(&xr_usb_serial->data->dev, "%s - write %zd\n", __func__, count);
 +#else
        dev_vdbg(&xr_usb_serial->data->dev, "%s - write %d\n", __func__, count);
 +#endif