mariadb: move mariadb-common into its own package
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 17 Nov 2019 14:54:16 +0000 (15:54 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 17 Nov 2019 14:54:17 +0000 (15:54 +0100)
This moves mariadb-common into its own (tiny) package in preparation for
moving out libmariadb as well. Otherwise the library would have a
dependency on the big mariadb package.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/mariadb-common/Makefile [new file with mode: 0644]
utils/mariadb-common/conf/my.cnf [new file with mode: 0644]
utils/mariadb/Makefile
utils/mariadb/conf/my.cnf [deleted file]

diff --git a/utils/mariadb-common/Makefile b/utils/mariadb-common/Makefile
new file mode 100644 (file)
index 0000000..ce87718
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2019 Sebastian Kemper <sebastian_ml@gmx.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mariadb-common
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
+PKG_LICENSE:=GPL-2.0
+
+CONF_DIR:=/etc/mysql
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mariadb-common
+  SECTION:=utils
+  CATEGORY:=Utilities
+  URL:=https://mariadb.org/
+  SUBMENU:=Database
+  TITLE:=MariaDB database common files
+  DEPENDS:=
+endef
+
+define Package/mariadb-common/conffiles
+$(CONF_DIR)/my.cnf
+endef
+
+define Package/mariadb-common/description
+MariaDB is a very fast and robust SQL database server.
+
+This package includes shared files, for example $(CONF_DIR)/my.cnf.
+
+endef
+
+define Package/mariadb-common/install
+       $(INSTALL_DIR) $(1)$(CONF_DIR)
+       $(INSTALL_CONF) conf/my.cnf $(1)$(CONF_DIR)
+endef
+
+define Build/Compile
+endef
+
+$(eval $(call BuildPackage,mariadb-common))
diff --git a/utils/mariadb-common/conf/my.cnf b/utils/mariadb-common/conf/my.cnf
new file mode 100644 (file)
index 0000000..7583c7c
--- /dev/null
@@ -0,0 +1,22 @@
+# The MariaDB configuration file
+#
+# The MariaDB/MySQL tools read configuration files in the following order:
+# 1. "/etc/mysql/my.cnf" (this file) to set global defaults,
+# 2. "/etc/mysql/conf.d/*.cnf" to set global options.
+# 3. "~/.my.cnf" to set user-specific options.
+#
+# If the same option is defined multiple times, the last one will apply.
+#
+# One can use all long options that the program supports.
+# Run program with --help to get a list of available options and with
+# --print-defaults to see which it would actually understand and use.
+
+#
+# This group is read both both by the client and the server
+# use it for options that affect everything
+#
+[client-server]
+
+# Import all .cnf files from configuration directory
+!includedir /etc/mysql/conf.d/
+
index 202c9363fd95df45a0ffe54bc82eb57914919384..9c8b0eedc4ed3cd95873dad5e732a616ff4c13de 100644 (file)
@@ -298,23 +298,6 @@ $(subst $(space),$(newline),$(MARIADB_CLIENT_EXTRA))
 
 endef
 
-define Package/mariadb-common
-  $(call Package/mariadb/Default)
-  TITLE:=MariaDB database common files
-  DEPENDS:=
-endef
-
-define Package/mariadb-common/conffiles
-$(CONF_DIR)/my.cnf
-endef
-
-define Package/mariadb-common/description
-$(call Package/mariadb/description/Default)
-
-This package includes shared files, for example $(CONF_DIR)/my.cnf.
-
-endef
-
 define Package/mariadb-server
   $(call Package/mariadb/Default)
   DEPENDS:=mariadb-server-base
@@ -559,11 +542,6 @@ define Package/mariadb-client-extra/install
        $(foreach b,$(MARIADB_CLIENT_EXTRA),$(call Package/mariadb/install/bin,$(1),$(b));)
 endef
 
-define Package/mariadb-common/install
-       $(INSTALL_DIR) $(1)$(CONF_DIR)
-       $(INSTALL_CONF) conf/my.cnf $(1)$(CONF_DIR)
-endef
-
 define Package/mariadb-server/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(foreach b,$(MARIADB_SERVER),$(call Package/mariadb/install/bin,$(1),$(b));)
@@ -622,7 +600,6 @@ $(eval $(call BuildPackage,libmariadb))
 $(eval $(call BuildPackage,mariadb-client))
 $(eval $(call BuildPackage,mariadb-client-base))
 $(eval $(call BuildPackage,mariadb-client-extra))
-$(eval $(call BuildPackage,mariadb-common))
 $(eval $(call BuildPackage,mariadb-server))
 $(eval $(call BuildPackage,mariadb-server-base))
 $(eval $(call BuildPackage,mariadb-server-extra))
diff --git a/utils/mariadb/conf/my.cnf b/utils/mariadb/conf/my.cnf
deleted file mode 100644 (file)
index 7583c7c..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-# The MariaDB configuration file
-#
-# The MariaDB/MySQL tools read configuration files in the following order:
-# 1. "/etc/mysql/my.cnf" (this file) to set global defaults,
-# 2. "/etc/mysql/conf.d/*.cnf" to set global options.
-# 3. "~/.my.cnf" to set user-specific options.
-#
-# If the same option is defined multiple times, the last one will apply.
-#
-# One can use all long options that the program supports.
-# Run program with --help to get a list of available options and with
-# --print-defaults to see which it would actually understand and use.
-
-#
-# This group is read both both by the client and the server
-# use it for options that affect everything
-#
-[client-server]
-
-# Import all .cnf files from configuration directory
-!includedir /etc/mysql/conf.d/
-