cni-plugins: depend on kmod-veth
authorDaniel Golle <daniel@makrotopia.org>
Mon, 29 Mar 2021 21:23:54 +0000 (22:23 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 15 Nov 2021 20:03:48 +0000 (20:03 +0000)
cni-plugins makes use of veth, make sure kernel module is installed.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit 1b25b6e23965a68c2366bdde3a9efcc6467ce8c5)

utils/cni-plugins/Makefile

index 279625e4b83a78e62ddccfe64e67f5ace18acdaf..7db7f9498c8433aaf218afdb40839d28013264b5 100644 (file)
@@ -31,7 +31,7 @@ define Package/cni-plugins
   CATEGORY:=Utilities
   TITLE:=cni-plugins
   URL:=https://github.com/containernetworking/cni-plugins
-  DEPENDS:=$(GO_ARCH_DEPENDS) +ip-full
+  DEPENDS:=$(GO_ARCH_DEPENDS) +ip-full +kmod-veth
 endef
 
 define Package/cni-plugins/description